MPICH problem on PGI 7.1

good day,

I installed the version 7.1-6 of the PGI compiler.
And everything is going very well but when i try run mpif90 I get the following error:

[root@wrf ~]#mpif90
/usr/bin/ld: cannot find -lmpichf90

anyone can help me please ?

Thank you so much!.

sorry for my bad english =/


Please make sure you set PGI environment variable. For example, setenv PGI /opt/pgi if you install under /opt/pgi.


I did everything you told me, but now I get this error:

[root@wrf bin]# /opt/pgi/linux86-64/7.1/mpi/mpich/bin/mpif90
/opt/pgi/linux86-64/7.1-6/libso/f90main.o: In function main': f90main.c:(.text+0x3c): undefined reference to MAIN_’

can you help me again please ?

That is not an error. You have to compile some file. You can’t just run mpif90 alone. For example,

% mpif90 main.f

Consult documentation for more information on how to use it.


thank you so much hongyon!

Problem solved! =)


I encountered a similar problem as UdeG but I was unable to solve it.

I installed PGI 7.1-1 and mpich under a 2 x 64bit Opteron running on ubuntu 8.04 and set environment path to /opt/pgi/linux86-64/7.1/mpi/mpich/bin but when I try to compile a simple mpihello.f90 program I get this message:
/usr/bin/ld: cannot find -lmpichf90

Any ideas?


Hi gefstath,

What PGI product do you have, Workstation or CDK? What compiler are you using to link with and with what options?

  • Mat

Hi Mat,

I am rather new in Linux. I use PGI 7.1-1 Workstation and I installed the MPICH package which is included in the installation. I have set the environmental variables so PGI works fine. But when I tried to use the mpif90 (path to /opt/pgi/linux86-64/7.1/mpi/mpich/bin) command in a simple program I got that error message. I am trying to run a much more complicated application in parallel mode. As far as the “linking part” you asked me … I did nothing. I downloaded the mpich ubuntu package but it didn’t help either.

Thanx in advance