Multiple sources multiple rtspsink ,deepstream-app run for a while the fps drop to zero :**PERF: 0.00 (24.43)

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU) GPU
**• DeepStream Version 5.1

• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only) 450.80.02
• Issue Type( questions, new requirements, bugs) bugs
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

here is my config file:

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=1

[tiled-display]
enable=0
rows=2
columns=2
width=1280
height=720
#width=960
#height=640
gpu-id=0
nvbuf-memory-type=0

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
num-sources=1
uri=file://../road_truckoverload.mp4
gpu-id=0
cudadec-memtype=0

[source1]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
num-sources=1
uri=file:///opt/nvidia/deepstream/deepstream-5.1/samples/pytmp/test/videos/road_truckcover.mp4
gpu-id=0
cudadec-memtype=0

[streammux]
gpu-id=0
batch-size=4
batched-push-timeout=40000
enable-padding=1
## Set muxer output width and height
width=1280
height=720

[sink2]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming 5=Overlay
type=4
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=1
qos=1
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
# set below properties in case of RTSPStreaming
rtsp-port=8554
udp-port=5400
source-id=0

[sink3]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming 5=Overlay
type=4
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=1
qos=1
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
# set below properties in case of RTSPStreaming
rtsp-port=8555
udp-port=5401
source-id=1

[primary-gie]
enable=1
gpu-id=0
# Modify as necessary
model-engine-file=../models/yolo/model_b2_gpu0_int8.engine
#!batch-size=4
batch-size=2
#Required by the app for OSD, not a plugin property
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
gie-unique-id=1
#config-file=config_infer_primary_trafficcamnet.txt
#config-file=config_infer_primary.txt
config-file=config_infer_primary_yoloV3.txt
nvbuf-memory-type=0
interval=5

then the FPS drop to zero
**PERF: FPS 0 (Avg) FPS 1 (Avg)
**PERF: 24.25 (25.27) 26.30 (25.28)
**PERF: 23.93 (25.29) 23.14 (25.30)
**PERF: 25.75 (25.28) 28.11 (25.29)
**PERF: 25.33 (25.25) 21.57 (25.26)
**PERF: 24.86 (24.99) 27.09 (24.98)
**PERF: 0.00 (24.43) 0.00 (24.42)
**PERF: 0.00 (23.90) 0.00 (23.89)
**PERF: 0.00 (23.39) 0.00 (23.38)
**PERF: 0.00 (22.89) 0.00 (22.88)
**PERF: 0.00 (22.42) 0.00 (22.41)
**PERF: 0.00 (21.97) 0.00 (21.96)
**PERF: 0.00 (21.54) 0.00 (21.53)
**PERF: 0.00 (21.12) 0.00 (21.11)
**PERF: 0.00 (20.72) 0.00 (20.71)

Any suggestion on how to fix it would be greatly appreciated.
Thanks

Can you try to change “sync=1” to “sync=0” in all [sink] groups?

Thanks for your reply.
It doesn’t work.

**PERF:  FPS 0 (Avg)    FPS 1 (Avg)
**PERF:  57.49 (59.25)  63.06 (65.21)
**PERF:  64.25 (59.24)  70.90 (65.21)
**PERF:  49.70 (59.22)  54.67 (65.18)
**PERF:  56.26 (59.22)  61.89 (65.19)
**PERF:  59.19 (59.22)  65.11 (65.19)
**PERF:  65.45 (59.23)  72.00 (65.19)
**PERF:  51.30 (59.22)  56.80 (65.18)
**PERF:  51.64 (59.20)  56.61 (65.16)
**PERF:  59.92 (59.20)  65.91 (65.16)
**PERF:  68.19 (59.21)  74.78 (65.17)
**PERF:  67.88 (59.25)  75.21 (65.21)
**PERF:  66.10 (59.17)  72.27 (65.13)
**PERF:  0.00 (59.03)   0.00 (64.97)
**PERF:  0.00 (58.89)   0.00 (64.82)
**PERF:  0.00 (58.74)   0.00 (64.66)
**PERF:  0.00 (58.60)   0.00 (64.50)
**PERF:  0.00 (58.46)   0.00 (64.35)
**PERF:  0.00 (58.32)   0.00 (64.19)
**PERF:  0.00 (58.18)   0.00 (64.04)
**PERF:  0.00 (58.04)   0.00 (63.89)

Can you send road_truckoverload.mp4 file for us to test? I can not reproduce the problem.

The file is too big to upload, I shared it on google drive:
https://drive.google.com/file/d/130IUy8yf0ljVHvjmtyfXXdi9q2G0N0gU/view

I can not reproduce the error with the same video file and config file you post here.

Okay, thank you for your time