MX250 power managment not working

After installing latest nvidia drivers on Arch linux I can see, that all of my video devices are always in full power mode, even if there is no heavily graphic related programs (only terminal + firefox running):

[roworu@arch ~]$ sudo  cat /sys/class/drm/card*/device/power_state

Hardware description:
Huawei matebook 13 (2020)
Nvidia MX250
nvidia-bug-report.log.gz (229.1 KB)

I’m new here, so, please, tell if there is any more information I could provide.
Thank you!

Dynamic power management is only supported on Turing and newer. Your MX250 is Pascal-based so can’t use runtime pm.

1 Like

Understood. Many thanks, @generix !

Re-reading the docs on it, they’ve become stragely ambigious on recent driver releases. Please try kenel parameter or module option

1 Like

Thank for your update. After adding this to kernel parameter got no changes:

[roworu@arch ~]$ sudo cat /etc/default/grub | grep nvidia
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3  nvidia.NVreg_DynamicPowerManagement=1"
[roworu@arch ~]$ sudo  cat /sys/class/drm/card*/device/power_state

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.