My AGX Xavier won't boot properly

My AGX Xavier to boot, boot black screen and the top left corner have been flashing cursor, try to use the CTRL + Alt + F1 - F7 all have no reaction, I changed the/boot/extlinux extlinux. Conf file, and then use gpio refresh DTB restart when that is.

How should be solved excuse me, do not need to brush machine finally

hello ChuZiHang,

may I know which release image you’ve flashed to the target.
it seems you’re not install the ubuntu desktop. are you able to setup serial console and gather the logs for reference?

After the logo of Nvidia appeared, the cursor kept flashing. Before, it should be loading some command lines. I don’t know Linux very well, how should I operate?

hello ChuZiHang,

you’re working with Jetson AGX Xavier DevKit, right?
it’s J501 to setup the serial console,
by default, it’ll register the tty port as ttyUSB3, the default baud-rate is 115200/8n1. you may use serial port utility to communicate with the target,
for example, $ picocom -b 115200 /dev/ttyUSB3

How do I connect it using a serial port? I don’t see a direct serial port, is type-C used?

hello ChuZiHang,

you should check Jetson AGX Xavier Developer Kit User Guide,
it’s port J501, a micro-USB connector provides access to the UART console.

How do I check the device after it is connected? How should the next operation?

What software should I use to operate my device? Like send a command line?

hello ChuZiHang,

once you have micro-USB to connect your target, please enable serial port utility to enter serial console, $ picocom -b 115200 /dev/ttyUSB3


It doesn’t look right

you’ve already in the serial console…

But I can’t solve the above problem, I can’t find the boot folder, I didn’t change the/boot/extlinux extlinux. Conf file after using gpio refreshed the DTB restart process can’t boot? So I want to change back but I can’t find the /boot directory

hello ChuZiHang,

could you please let us know which release image you’ve flashed to?
please check NVIDIA SDK Manager | NVIDIA Developer for setting up your development environment, you’ll also download the latest JetPack release image.


That’s it. One cursor, right? Isn’t there a way to use it without brushing?
My kernel version is R32.5.1

Only one cursor kept flashing

Hello, is there any solution to yesterday’s problem?

hello ChuZiHang,

did you flashed the JetPack release image?
please share your exactly steps to reproduce this issue, thanks

There was no attempt to brush because there was still data.

I before operation is changed/boot/extlinux/extlinux conf file, and then use the gpio tool set some DTB

hello ChuZiHang,

may I also know what’s the original status. are you able to login ubuntu desktop?
could you please also gather some bootloader logs for details.

I can’t log in to my desktop. I’ve been in this black screen blinking cursor screen