My Jetson Xavier NX developer kit is not turning on

My Jetson Xavier NX developer kit is not turning on.The green light turns on for a sec then turns off. I have tried reflashing but it didn’t resolve my issue.

Any Help is appreciated

What do you have plugged into your Xavier NX? Unplug everything from it, then plug in the power cable and see if it remains on. If it does not, try a different power adapter if possible.

I agree with @matt_h. USB devices (other than keyboard/mouse) can consume a lot of power if you are using anything else. The power supply itself is usually at fault though for such power off situations. What people often fail to realize is that not only does the power supply have to meet minimum ratings, such a power source also needs good regulation. If the supply cannot hold a sufficiently tight voltage tolerance during boot, then it will shut itself off.


I tried removing all the peripherals, but its still not working. I do not have a spare charger at the moment though.

It is most likely the power source is at fault. I don’t know of another way to continue debugging without a known good power supply (a supply with above average regulation, not just one of a particular voltage and power rating).

Is there any way to get these repaired? do we have any official service centre for Nvidia?

NVIDIA does not repair these, but you can RMA. See:

I don’t know of anyone who repairs these, although someone might.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.