Nano can't boot this morning

Hi guys,
my nano worked always fine with 5V4A DC input but this morning it can’t boot up, or it keeps rebooting in 5 secs…the USB and ethernet connectors didn’t work either.
messages on screen shows:
tegradc tegradc.1: dpd enable lookup fail: -19
imx219 7-0010: imx219_board_setup: error during i2c read probe(-121)
imx219 7-0010: board setup failed

EXT4-fs error…

I tried to ssh by serial but only got unreadable messages. Also a image of putty to show the problem.
Could someone help me here? Is there anything I can do to recover my nano?

it’s a nano devkit, currently no peripherals connected

Same solution as my comment here.

Thanks Wayne!
I haven’t tried SDK manager yet, but I followed this guide:

and flashed both both QSPINOR memory & SD card (jetson-nano-qspi-sd).

The log from uart is still undreadable like this:

The dev-kit showes different error messages on screen like this:

Shall I try to flash it again by SDK manager?

Yes, try with sdkmanager.

And your uart setup probably has something wrong.

Thanks, sdkmanager works and the devkit can work now.
Just wondering last time the devkit failed all in a sudden, will the same trouble happen repeatedly? definitely don’t want to flash the devkit again and again…

Hi Wayne, I have to reopen this case because today the devkit failed again…
this time I think the TF card is probably broken, as shown in the photo

shall I prepare a new os image?

This log indicates the bootloader and kernel are fine. However, it fails to load the rootfs.

Changing another sdcard and flash it with sdkmanager should help.

Even if the SD card is still good (and probably it is not) the content of the rootfs filesystem is definitely gone. You might see what happens if you try to read the SD card rootfs partition on another Linux computer.

Thanks Wayne, flashed a new image and the devkit can work now

yes the filesystem was gone, fortunately the SD card was not damaged

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.