New nano fails to boot for the first time

i got a problem like this and i don’t know why

1.096115] tegradc tegradc.1: dpd enable lookup fail:-19
[ 1.262720] imx219 6-0010: imx219_board_setup: error during i2c read probe (-121)
[ 1.262748] imx219 6-0010: board setup failed
not writing through dangling symlink ‘etc/resolv.conf’

[FAILED] failed to start load/save Random seed

[FAILED] failed to start udev kernel device manager

then completes installations in another lines giving OK status, display goes off then repeat the same steps with the same errors

although i installed the SD card image and removed it many times

I’m getting the same and I’m pretty sure the SD Card image is broken. I’ve downloaded twice, copied to two different SD Cards on 2 different computers and still the same.

I’m using Sandisk Ultra SDXC 64 GB cards, copying the image on Ubuntu 19.10.

I’m getting some indications the base image is broken, such as:

sudo dd if=sd-blob-b01.img of=/dev/sdc bs=1M status=progress
5064622080 bytes (5,1 GB, 4,7 GiB) copied, 194 s, 26,1 MB/s
dd: error writing '/dev/sdc': No space left on device
5012+0 records in
5011+0 records out
5254414336 bytes (5,3 GB, 4,9 GiB) copied, 194,292 s, 27,0 MB/s
[ 1866.143006] sd 4:0:0:0: [sdc] tag#0 access beyond end of device
[ 1866.364983] sdc: detected capacity change from 63864569856 to 0
[ 9340.503868] Alternate GPT is invalid, using primary GPT.
[ 9340.503908]  sdc: sdc1 sdc2 sdc3 sdc4 sdc5 sdc6 sdc7 sdc8 sdc9 sdc10 sdc11 sdc12 sdc13 sdc14
[ 9350.304690] JBD2: no valid journal superblock found
[ 9350.304693] EXT4-fs (sdc1): error loading journal
sudo sgdisk -v /dev/sdc
Caution: invalid backup GPT header, but valid main header; regenerating
backup header from main header.

Warning! Main and backup partition tables differ! Use the 'c' and 'e' options
on the recovery & transformation menu to examine the two tables.

Warning! One or more CRCs don't match. You should repair the disk!
Main header: OK
Backup header: ERROR
Main partition table: OK
Backup partition table: ERROR

Is there any alternate download or older/new image available for verification?

Hi ahmedakka97,

Could you try to flash with JetPack again to see if can boot up successfully?

hi kayccc,
I tried to flash the jetpack for 3 times but having the same error,
and I tried to flash with SDK but it failed to flash and didn’t reach the step (the stage showing the errors above ) I reached when did the SD card image way

Hi ahmedakka97,

Generally, such error indicates the rootfs on sdcard is broken. The reason behind it might be lots.

  1. I just saw you said " Ubuntu 19.10.". Is your host a ubuntu19.10 machine?

  2. Are you using a jetson nano devkit? If so, could you tell us your step in sdkmanager? Just want to make sure nothing goes wrong.

  3. I am not sure what did you mean in below description.

and I tried to flash with SDK but it failed to flash and didn’t reach the step (the stage showing the errors above ) I reached when did the SD card image way

It is better to clarify your term because normally we use “flash” when we install sdkmanager/jetpack and use “sdcard image” when you try to use the sd-blob-b01.img.

  1. Have you ever tried different sdcard?