Problem: Jetson Nano is not booting after mistakenly changing boot directory

Background: The Jetson Nano 4GB was originally booting from internal memory. I wanted it to boot from an SD card I had installed, but I was reading that I needed to change the boot directory to the SD card rather than the eMMC. Thus, I changed the boot directory from mmcblk0p1 to mmcblk0. This was obviously an enormous mistake in hindsight, because now the Jetson Nano will not boot at all.

Error messages were present in the boot log, including:

[1.163207] tegradc tegradc.1: dpd enable lookup fail:-19
[1.331484] imx219 7-0010: imx219_board_setup: error during i2c read probe (-121)
[1.331551] imx219 7-0010: board setup failed
[1.355465] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[1.355552] imx219 8-0010: board setup failed
mount: /mnt: wrong fs type, bad option, bad superblock on /dev/mmcblk0, missing codepage or helper program, or other error.
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

I tried connecting to the Jetson Nano using Putty and Tera Term on a Windows 10 host machine on COM2, but the connection could not be established.
I also tried running sdkmanager on a Linux 20.04 host machine, but even when enabling the correct USB port, the board could not be recognized by the VM.

Known non issues:
The cable connecting the Jetson Nano to the PC is the right kind, as it worked to establish an SSH connection before I idiotically changed the directory.
The virtual machine, USB port, and sdkmanager are all not the cause of the issue, as I was encountering the same problem on the other setups.

Request for solution:
How do I wipe the Jetson nano and flash it with the correct image despite the nano not being able to boot? I’ve already consulted the other forums to the best of my abilities. Please let me know if you have any potential solutions or need any further clarification. I’ll edit this post as necessary to provide more relevant context.

Please have a host PC with Ubuntu 18.04 to install SDK manager to flash you Jetson Nano via JetPack 4.6.3, the VM is not supported,

Hi nlbausinger,

Are you using the devkit or custom board?

Please remove SD card and re-flash the board (to eMMC) at this moment.
Make sure your board could boot up from eMMC first and then insert SD Card to flash into.

I’m using a jetson nano 4GB version. The SD card has already been removed. How can I flash from the eMMC if the boot directory is wrong?

Can I use a host machine that has 20.04 instead? According to the documentation that should be supported.

No, for jetson nano, only ubuntu 18.04 is okay. Ubuntu 20.04 is for jetpack5 on Orin + Xavier.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.