Jetson Nano 4GB not booting up

I accidentally flashed 2gb image to a 4gb Jetson Nano, and it asked me to reboot, after that that onwards it never booted neither with the proper image nor the wrong one

I tried changing the power supply, flashing another sd card, shorting the reset pen but nothing seem to work
It just gets stuck on the Nvidia logo picture but never proceeds

There is boot content within the QSPI memory of the module itself which is now mismatched with the version in the SD card. Flash the Jetson itself with JetPack/SDK Manager (the version intended to work with that SD card).

1 Like

I have been trying to install the jetpack sdk … but I didn’t manage to install it … i tried to install the sdk manager on a VM first but i could connect the jetson nano to it … i tried installing on the another jetson nano (2gb one) … but it refuses due to conflict on the architecture being arm64 instead of amd64 …

Aren’t there other methods I can recover the jetson nano? … or is there an sdk that is compatible with windows?


Sdkmanager does not support well on VM. Please use a native ubuntu 18.04 x86_64 host.

x86_64 here means you cannot use another jetson to flash.

Jetsons are the wrong architecture to run the flash software in. FYI, the reason VMs are not supported is because (A) they all have different setup methods you would need to use depending on vendor (which isn’t something NVIDIA has knowledge of and can’t really insert itself into VM vendors), and (B), the USB passthrough has to be 100% of the Jetson to the VM at all times (VMs fail this quite often unless the user knows how to dedicate the Jetson’s USB to the VM…the Jetson disconnects and reconnects during flash, and often, even if initially VM flash starts working, it will fail in the middle). This isn’t to say a VM can’t work, but you are far better off to just dual install Ubuntu 18.04 to a second boot of the host PC (and soon probably Ubuntu 20.04 when the next generation of flash software comes out).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.