Jetson Nano 2GB not booting up

Hi all, I am trying to setup my Nano for my project. It was booted but it said the installation failed without mentioning any reasons. I restarted the Nano as per the advice from the popup window but since then I have been unable to boot it up. I have tried formatting the SD and flashing it again and nothing seems to work. The LED is lighting up but nothing is showing on my monitor. The image that I was using is built with JetPack 4.6.

Please help if you have any idea what is going on with my Nano, I really need it to have progress on my project.

Thank you.

Sounds like you have the dev kit since it is the SD card model. Realize that there is other memory on the SD card model (QSPI memory) which contains boot content. The layout of this has changed over time, and the SD card partition for the newer 4.6 might be incompatible with what is on the QSPI. Likely if you have a proper 4.6 SD card, then flashing the Jetson itself using JetPack/SDK Manager from that release will allow it to boot (in other words, if not just the SD card is from 4.6).

Note that otherwise you’d want to include a serial console boot log. See:
https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

Thank you for the explanation.

I am not understanding this part though, does it mean I will need to flash the SD card with older images? I have tried booting the Nano with both Ubuntu 20.04 and 18.04 but it is still not booting up.

The SD card model Nano has both memory internal to itself (used for setting up boot), plus whatever is on the SD card. Both have to be of compatible version. The internal memory is the “QSPI” memory.

There have been changes to what software is used in QSPI, such that older releases on the SD card need the older QSPI software, and newer releases of SD card software will require newer releases to be programmed into the QSPI. This means that despite it looking like the only thing needed is to change the SD card that this is not the case. The Nano itself must be flashed even though the rootfs is on separate SD card media. Mixing versions won’t behave well. Consider flashing the Nano itself and not just the SD card.

All of the current releases would put Ubuntu 18.04 onto the Nano. The only case of caring if it is 18.04 versus 20.04 is for the host PC which performs a flash. You will have to wait if you want the Nano itself to use Ubuntu 20.04 (I wouldn’t think this is too far off, but there have not been any official announcements).

1 Like

Thanks a lot for the explanations. I’ll look into this and also try to get the console output from the Nano.