Jetson Nano 4GB Developer Kit errors during initial boot

Hi, I bought and just received the NVIDIA Jetson Nano 4GB developer kit. I installed the software for the jetson nano from NVIDIA’s website and followed their instructions to flash the image to an SD card (32GB) and set up the jetson nano. However, every time I try to boot the jetson nano for the first time, it gives me an error saying “imx219 7-0010: imx_board_setup: error during i2c read probe.”

After about a minute it gives me another error saying “cp: not writing through dangling synlink ‘etc/resolv.conf’”. It then proceeds to display various other things but even after 20 minutes, it doesn’t boot. I tried reflashing the image to the SD card, using a different power supply, and using both the USB and barrel jack to power the board, but nothing worked. Is there anything else I could try, and is my jetson nano’s hardware damaged?

There is nothing plugged into any of the ports, and my monitor is a 4k monitor connected by HDMI.


We suggest re-flash the system through SDKManager and try again. You can install it on Linux host PC in Ubuntu 18.04:
SDK Manager | NVIDIA Developer

and use it to flash Jetson Nano developer kit. The latest release for Jetson Nano is Jetpack 4.6.3.

Hello, thanks for the reply.

I am new to this software and device, so I’m sorry if this question is dumb. When you mentioned re-flashing the system, does that mean re-flashing the software to the SD card or re-flashing some software built into the Jetson Nano (like BIOS on a PC)? Thank you.

I attempted to install the software to the Jetson Nano, but the SDK Manager wouldn’t detect my board. The laptop I was using runs Ubuntu 20.04, so is that the reason my board wasn’t detected? Thanks.

We would suggest use Ubuntu 18.04. But on 20.04, you may try the manual steps in developer guide

Please check To flash Jetson Developer Kit operating software section. Not sure if it works on 20.04 but you may give it a try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.