Can't boot Jetson Nano, even with newly flashed cards

Hi, I had my Jetson Nano for more than year, I didn’t really use it in the last 6 months but know I can’t get it to boot correctly. I’ve tried 2 SD cards, tried to flash them with BalenaEtcher on mac, with the terminal on mac and with the terminal on Ubuntu and it’s always the same error (see below).

Any advice ?

Here is an OCR of the error:

1.1471443 tegradc tegradc.1: dpd enable lookup fail:-19 
1.3111481 imx219 7-0010: imx219_boarksetup: error during i2c read probe (-121) 
1.3112151 imx219 7-0010: board setup failed 
1.33504131 imx219 8-0010: imxZ19_board_setup: error during i2c read probe (-121) 
1.32151053 imx219 8-0010: board setup failed 
1.7848011 EXT4-fs error (device mmalkOpl): ext4Jookup:1603: i node #2: comm mount : deleted i node referenced: 655370 1.7971801 EXT4-fs error (deuice mmcblkOp1): ext4_lookup:1603: inode #2: comm mount : deleted inode referenced : 655370 
mount : /mnt/sys: mount(Z) system call failed: Structure needs cleaning. 
cp: not writing through dangling symlink letc/resolu.conf' 
1.9566541 EXT4-fs error (device mmcblkOp1): ext4_lookup:1603: inode #2: comm init: deleted inode referenced : 655370 
1.9894683 EXT4-fs error (device mmcblkOp1): ext4_lookup:1603: inode #2: comm systemd: deleted inode referenced : 655370 
1.0047621 systemdfll: Failed to determine whether /sys is a mount point : Structure needs cleaning 2.0139741 EXT4-fs error (device mmcblkOp1): ext4_lookup:1603: inode #2: comm systemd : deleted inode referenced : 655370 
2.028263 EXT4-fs error (device mmcblkOp1): ext4Jookup:1603: inode 112: comm systemd : deleted inode referenced : 655370   
Failed to mount early API filesystems, freezing. 
2.0401561 systemd[1]: Freezing execution. 

Hi @williamd38b9

How are you generating the image for the sdcard?

You can create an sdcard image by using the followin command documented at Flashing to an SD

sudo ./ -o nano.img -b jetson-nano -r 300

Where -r depends on your board model revision, 300 being b00 and b01.

You can then use etcher to flash it, also you can use dd instead of etcher to see if it behaves better:

sudo dd if=<sd_blob_name> of=/dev/mmcblk<n> bs=1M oflag=direct

Please let me know if this helps you

Best regards,
Roberto Gutierrez
Embedded Software Engineer,

Hi @robertogs2, I downloaded the image in this tutorial: Is there another image I should be using ?

I just tried to redownload the image from the site and flash it using Balena Etcher and it worked ! Should have tried that sooner… !

1 Like

Move topic to jetson nano forum.

I’m sorry I thought it was in the Jetson Nano forum, how do I move it ?

I mean I already helped you move it.

Wonderful, thanks !