Need help to enable selinux on nano

I tried to install selinux on nano.But got these errors.
Could you help us to enable selinux on nano?

root@DL-aaaaaa010100038b:/home/vaitl# apt install selinux
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
selinux : PreDepends: grub-pc but it is not installable
Recommends: selinux-policy-ubuntu but it is not installable or
E: Unable to correct problems, you have held broken packages.

I’ve never tried to use SElinux with a Jetson, but I imagine the package you are speaking of is for passing the right boot arguments…and since Jetsons are not PCs, they don’t have GRUB (they have CBoot/U-Boot depending on which Jetson). You could pass arguments via edit of the device tree and perhaps edit of “/boot/extlinux/extlinux.conf”. The trick is that you have to have the filesystem set up for labels. The tools which work with SElinux may still be installable…not sure, I don’t plan on adding SElinux to a Jetson. I’d advise researching what installs tools, versus what installs configuration…the GRUB failure is because it is configuration for software which doesn’t exist in the Jetson world. Once tools are in place you can easily add the command line arguments.

NOTE: I’d look first at the semanage packages.

Thank you for your reply!
I will check this.Or i will try to install apparmor on nano instead.