Newbie cannot get Jetson nano to work

Hi I am trying to get Jetson nano 2GB to work in headless mode for the intial startup. I have the cables connected as described in the “getting started guide.”

The COM Port is not listed in the device manager. I have tried clicking on “show hidden devices” and “install legacy hardware” from the action tab in device manager, but no success.

It shows CDC NCM and CDC Serial under other devices, but I still have not found the COM Port. I also show D:\ L4T and some other documentation. I tried reading the readme file, and installing the driver from the .inf file, but still no success.

So it appears that it is connected to my laptop, but I don’t know how to get the com port for PuTTY.

I’m not sure where to go with this.

One of the other responses I got from the forums is that I need a different USB cable? That didn’t seem correct, but I don’t know.

Why can’t I find the com port? What’s going on? Please help!

hello pettinger.michael,

are you having windowOS to connect to a Nano platform?
please setup your environment with ubuntu for verification, thanks

I’m using Windows on my laptop. I have it setup as described hear: https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-2gb-devkit#setup

I’m trying to use headless mode.

hello pettinger.michael,

were your Nano platform already power-on and ready for connection?
you may also plug-in the usb-keyboard to enter commands (i.e. $ ifconfig -a) to check the IP address for you to remote login.
thanks

I waited the requisite 1 minute before connecting to the laptop. I don’t have an additional keyboard, mouse or monitor for the nano. That’s why I am trying to get it to work in headless mode. I can find the ip address for the nano on my laptop, but the instructions in the getting started guide are telling me to find the COM port that it is associated with, but that doesn’t show up in my device many.

i am fairly sure that windows recognising my 4GB nano as an ethernet adaptor when connecting via the usb cable, and not a serial com port.

I am not sure if you would be able to login using putty for ssh as a headless device as the initial configuration won;t have happened yet but you could use a ttl-usb 3.3v serial console cable, connected to the serial debug header (sometimes called UART or serial debug port)

I have an arduino that I use for ttl-usb but you might need a voltage divider to drop the 5v to 3.3v

you can use Putty with the serial com port (assigned to the ttl-usb adaptor) and should be able to complete the initial setup

@wodgey yes it shows up as an unidentified network. It’s clearly recognized by my computer but I can’t get access to it. I’m just trying to use what they recommended in the getting started guide on Nvidia’s website. Putty is clearly not working the way they describe. What would you recommend doing? Sorry if I’m asking stupid questions. I’m trying to learn a lot of things.

I am also a newbie at linux and have been for nearly 20 years! lol. it’s ok.

I haven;t looked at the quick start guide you refer to, instead I am referencing knowledge obtained a few years ago, for setting up a different SBC in headless mode (not important but it was a Banana Pi R1 router board, with IPFire iamge, that had no hdmi drivers, so could only use a ttl-usb adaptor)

if you google “jetsonhacks uart ttl” you’ll find a video guide that he’s created for connecting to the serial port on the nano.

once connected to that port with a usb-ttl cable (as mentioned, I have an arduino that I have used in the past for this purpose but cannot remember off the top of my head, if it is happy to play at 3.3v or if it is 5v, so it might be better to purchase a dedicated cable rather than using an arduino. I did that because I had one available and no other reason) you can use putty to connect to the serial port and it will be similar to having a screen connected. I suspect that you’ll be presented with the text version of the initial startup scripts (choosing username, location/timezone,password etc) but this is guesswork on my part as I haven’t actually tried it. My arduino is actually in storage in my mothers loft, over 100 miles away

I will read the quick start guide and see if I can make sense of the problem you are having but I am unable to reboot to windows currently as I am attempting to recompile the kernel on my laptop, to get my own SD Card reader to work.

edit2add.
I have had a look at that guide. like I said, I believe my nano 4gb dev kit presents itself as an ethernet adaptor rather than a serial com device. It could be a difference in the way the boards/SD card image is configured, it could be a guide for an older version of the image OR it could be that I am mistaken (it has certainly happened before)

However, the usb-ttl cable method should still work even if I am incorrect about windows seeing my device as a network device. I only plugged it in the one time, on the day I purchased it, out of curiosity. But I am sure I remember correctly ssh’ing into it - but this was after going through the initial setup using a keyboard and monitor

@wodgey I had a go at my arduino uno as well (I hadn’t played with that for awhile). I was able to connect to it with the USB. It too uses this COM Port in it’s IDE to upload sketches.

I have had some minimal success with the nano.

As you can see it shows it connected to COM3, however when I try to launch PuTTY I get this:

I’m starting to wonder if because the nano hasn’t gone through the intial setup it’s just not allowing PuTTY in. Is that possible?

I don;t know, as my 4GB model behaves differently. mine presents itself as a network connection that i can ssh to on 192.168.55.1 - but I had already gone through initial setup.

However I can see the “warning” icon in device manager. What does the device properties page say about that?
What settings are you using for putty?
on my arduino, I needed to ground the reset pin, to allow me to use it as a ttl adaptor. Also, (and I feel patronising for saying so) have you remembered that a null-modem needs the tx-rx lines reversed (tx on one device goes to rx on the other, and vice versa)? using the uart should work at a much lower level than the usb port as it’ll be initialised very early in the process so I personally would focus on that

HOWEVER - have you tried searching google for the hardware id’s for those other two devices? it looks like they’re missing drivers too. that could be related

this is a long shot that may/not work - you could try chrooting to the sd card as root, then do the adduser stuff to create a login, edit the network settings to a static IP (possibly through netplan but I haven’t looked at my own device) and configure /etc/ssh/sshd to allow inbound connections. I am just spitballing here but once you have a user created and a network connection, you should be able to ssh to it

one other point I’ll add though is to make sure that you have the baud rate and parity settings correct in BOTH putty AND the device properties page in Device Manager.
I had a memory when out walking the dog of this being an issuefor me before as I;d set everything in putty but couldn;t connect. However when looking at the COM3 device in device manager (based on your info, I cannot remember what mine was now) it was at 9600 baud. when I made sure this was at 115200, all started to play nicely.

somethings really are just so much easier with Linux sometimes. Perhaps consider using a USB flash drive just for the purpose of live linux CD (there are guides on “persistant changes” online too, so that any apckages/settings you install/edit remain following a reboot.

Hi @JerryChang, I was never able to get PuTTY to work as described in the getting started guide. Even after trying for several days. I had to resort to buying an additional monitor, keyboard and mouse to plug into the nano. I was only able to wirelessly connect with Tera Term (which I found purely by accident). I would recommend that Nividia update their documentation in their getting started guide to make this more user friendly at least for beginners. It’s very frustrating to to follow all the instructions and not have it work.

hello pettinger.michael,

you may check https://developer.nvidia.com/nvidia-sdk-manager, System Requirements of the Host OS is Ubuntu Desktop 16.04 and 18.04 on x64 system.
you should go through ethernet via ssh to access the board,
or, please by default setup your environment with ubuntu desktop system.
thanks