"Next-gen" CUDA profiling in NSight 5.5 hangs Visual Studio

I’m trying out NSight 5.5 in Visual Studio 2017 (Version 15.4.1). Whenever I try to use the new “Next-Gen” CUDA profiling, I get a hang in Visual Studio while trying to read the report. The report is gathered successfully, but as soon as it appears in Visual Studio the entire application stops responding.

I’m using a GTX 1050ti with CUDA 9 on Windows 10 64-bit.

Hi, james_hancox

We have ever met the hang issue during developing, but after some fixes, it can not reproduce.

Can you share us your profile result(.nvreport) you can’t load ?

Also please answer

  1. If you specify less kernels to profile, can the report open correctly ?
  2. Are all samples have this issue ?
  3. Can you drag the .nvreport directly into VS2017, does this also happen ?

Hi veraj,

  1. I have tried limiting the profile run to a single kernel launch, but I still get the hang.
  2. When I generate the report for a simpler kernel, I can avoid the hang- looks like it’s related to complexity.
  3. I can’t find the .nvreport file in the usual c:\temp directory- looks like the “next-gen” profiling outputs a .nvp file instead. If I drag the .nvp file into VS2017, I can reproduce the hang.

I’m happy to share the .nvp file, but I can’t do so on a public forum due to company confidentiality. Do you have any more confidential way to communicate?


I will send a private message to you.

Can you also provide the sample together ? That would be best.

Hi, james_hancox

I checked your file.

I can drag to open successfully(never failed), but I do see “Not Responding” during switch pages, but this is not 100% reproducible, and after a while, it will recover back with responding correctly.

Anyway, I’ll share the file to dev to have a check.

Can you share the application also so that we can reproduce the load fail issue?

Hi Veraj,

I can’t share the application, I’m afraid- I’d need to also share some confidential data you need to run it, which we do not have permission to share.

The “Not Responding” problem is the same thing that I was seeing- the report would load in, but then Visual Studio became “Not Responding” for over 5 minutes, at which point I killed the app. Perhaps it would have started responding again if I had left it for longer, or perhaps it recovered more quickly on your system? Either way, it’s not exactly a useful workflow!