NGC CLI Client Error 403

Hi, when trying to pull anything from NGC on linux I get a 403 error.
For example:

$ ngc registry resource download-version “nvidia/jarvis/jarvis_quickstart:1.2.0-beta”
Downloaded 0 B in 2s, Download speed: 0 B/s
Client Error: 403 Response: - Request Id: Url: https://ngc.download.nvidia.com/models/org/nvidia/team/jarvis/recipes/jarvis_quickstart/versions/1.2.0-beta/files.zip?ak-token=exp=1623010467~acl=%2Fmodels%2Forg%2Fnvidia%2Fteam%2Fjarvis%2Frecipes%2Fjarvis_quickstart%2Fversions%2F1.2.0-beta%2Ffiles.zip*~hmac=af6ad6011e60a8661d23f25d0399737897e14b8173dfafc068ee87d9cf93ba22
Downloaded 0 B in 3s, Download speed: 0 B/s

Transfer id: jarvis_quickstart_v1.2.0-beta Download status: Failed.
Downloaded local path: /home/jarvis/Desktop/jarvis_b1.2/jarvis_quickstart_v1.2.0-beta
Total files downloaded: 0
Total downloaded size: 0 B
Started at: 2021-06-06 20:14:26.026720
Completed at: 2021-06-06 20:14:29.030664
Duration taken: 3s

It started happening randomly so I’m not sure what caused it.
At the beginning I assumed that it was a problem with Nvidia servers however visiting the URL manually downloads the files no problem.
The API key also seems to be validated and running $ngc diag all connects fine…

Any ideas? Starting to get desperate!

Having the same issues. I’m not sure why it just stopped. I tried creating a new key just in case. Still not working.

Thank you for sharing this feedback! Our team is currently investigating the root cause of this 403 error and working on a fix as a top priority.

We will be circling back here to keep you updated on the latest status.

We sincerely apologize for any inconvenience this may have caused, and greatly appreciate the support of our developer community. Thank you once again for your understanding.

NVIDIA NGC Team

1 Like

Good news! This issue has now been fixed. Please feel free to go ahead and retry pulling from NGC.

If you run into any troubles, we’re always constantly monitoring this Developer Forum for your feedback.

Appreciate your patience and understanding, and thank you once again for being a valued member of our community!

NVIDIA NGC Team