NGC key is invalid

NGC config set command is working
cd jarvis_quickstart_v1.2.1-beta command is working
bash command is not working and I am getting
NGC key is invalid.Please try again. Even after trying many times am getting the same error.
how do I slove this?

1 Like

Is the issue resolved ?

I am getting same issue.

Hi Nilesh,
No my issue is not yet solved.
What is your issue?

You may want to consult this thread, where this issue has been mentioned.

This issue has been noted by the development team, and they are monitoring the thread I link below, so I suggest you reply there.

But this post (on this thread), was the solution to the issue. However, I cannot install NVIDIA Jarvis 1.3.0 Beta, only 1.2.0 Beta. That is, by using this one-line code on the CLI. (Remove the around the DNS with your DNS IP along with changing the API Key)

I hope this helps.

There is error in script Script gets extra characters in apikey when it is extracted from config file.

Thanks and Regards,
Nilesh Parshetti


If you remove remove &> /dev/null part in login line in script, then you can get the actual error message, which was in my case about an issue with X11. Here is more details on this issue and how to fix it: docker login fails on a server with no X11 installed - Stack Overflow

What helped me, was the command:
sudo apt remove golang-docker-credential-helpers

But after that, as I understand, Docker starts to store it’s passwords unencrypted, so you might want to check some other solutions from this stackoverlflow thread. Anyway, first thing I would recommend doing is seeing actual error by removing &> /dev/null from the line
echo $NGC_API_KEY | docker login -u '$oauthtoken' --password-stdin &> /dev/null
in script.

I also get the same error when running script.

Is there any official solution to this problem or any new update?

“DNS solution” didn’t work for me.

I would really love to try an use Jarvis for my mini project but Im stuck with this :( .