No 3D acceleration in Xorg driver on Quadro card when Tesla is also installed

We had been running CentOS6 on two Dell Precision T7500’s that have a Quadro K4000 card as well as a Tesla K20c. After upgrading to CentOS7 I installed CUDA/nvidia driver via linux cuda repository so that installed are:


On starting X I get a “oh no” screen from GDM and the gdm logs show

** (process:5402): WARNING **: software acceleration check failed: Child process exited with code 1

In a text window I set DISPLAY and XAUTHORITY properly and running ‘glxinfo’ gives

Error: couldn’t find RGB GLX visual or fbconfig

If I shut down and simply remove the Tesla card and boot up everything is fine and 3D accel is working fine

There are no errors reported in the Xorg.0.log file. When the Tesla is in, CUDA appears to working okay

Can anyone explain what is going on and how I might fix this?


I removed the above RPMs and tried installing older drivers from the *.run packages. Once I got back to I got a working Xorg with 3D accelearation when the Tesla was installed. However now my CUDA-8.0 stuff no longer works since that driver is too old for CUDA 8.0


I removed the *.run package and all cuda RPMs. I then reinstalled from a cache copy of the cuda repo from April 2015 that had cuda-7-0 and nvidia-kmod 346.46 driver and everything works with that so far.

AFAIK, for a Quadro+Tesla combo you have to use the Quadro driver, not the Tesla one, i.e. the 384.69 display driver.

Quote driver info:

Since this is Linux, as far as I know there is only one unified driver, no separate installs for Quadro, Tesla, GeForce, etc. I downloaded the file and installed after removing kmod-nvidia and the packages that dependended on it. I still get the same error from GDM about no acceleration available.

I then uninstalled that package and removed all the CUDA 8.0 rpms. I then installed from a cache copy of the cuda repo from April 2015 that had cuda-7-0 and nvidia-kmod 346.46 driver and everything works with that so far.

So this appears to be a problem with the new drives since then.

I have the same problem with Quadro+Tesla. GLX failure with 384.66, but fine with 375.74.

Really irritating since this broke my cuda installation via the official repo.

Don’t ask me why, but different builds exist if you search at the Nvidia drivers page for either Tesla or any other gpu. For Tesla, you get version 384.66 and all others 384.69. Maybe a different team at Nvidia builds their own drivers now.
To get further infos, please install the non-working drivers, then run and attach the output tar.gz file to your post.


The official cuda repo only provides 384.66 and not 384.69. And as @PRaines said, 384.69 also did not work.

The weird thing is that the same 384.66 driver works on other machines (one with a single Quadro, another with two GeForce 1080).