Missing lcuda + no device Latest driver + SDK 1.1 creating trouble

I have a Fedora 8, 2.6.23 x86_64 kernel (eventually need to use Xen 2.6.18 Fedora 8) running on an Intel Xeon quadcore and I have installed NVIDIA driver from the site using the NVIDIA-Linux-x86_64-173.14.09-pkg2.run (latest available from nvidia). The graphics card is e-GeForce 8800GTX. I had some previous installations but I manually erased the files I thought could be left over before installing the driver (the driver is supposed to take care of this though). X server started correctly. Then I installed the toolkit using NVIDIA_CUDA_Toolkit_1.1_Fedora7_x86_64.run (couldnt find Fedora 8) as root and NVIDIA_CUDA_SDK_1.1_Linux.run as normal user.

Now compilation of project samples stops in between due to missing -lcuda (which I could not find anywhere on my system). I had read in the earlier posts that the newer drivers were supposed to install it but that doesnt seem to have happened.

That being one problem, now ./deviceQuery returns the following:

[font=“Courier”]There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”
Major revision number: -1
Minor revision number: -1
Total amount of global memory: -1 bytes
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 32
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 1350000 kilohertz


Press ENTER to exit…[/font]

I cannot run any of the examples that have compiled.

I have read the previous posts and tried changing grub menu etc. but nothing seems to help. I ultimately need to install and get this to work in Xen3.2.1 based kernel. So please help me out with a plain kernel so I can move to Xen.

Xen is not supported with CUDA.

If you’re using a Xen enabled kernel, that would explain the current problem.

No, right now I am working on a simple non-Xen kernel. I tried using an older version of the driver which had a patch for Xen but that did not work because of similar issues. So I moved to a non-Xen kernel to see if it worked there. No luck still :(

Never mind. My bad. Did not notice that CUDA currently works only with the 169.09 driver. Now need to make it work with a Xen patch. Any inputs?

I have the same problem for my 8800 GTX on 173.14.09

At least with drivers 169.12 and 173.14.05 all works properly, but not found any CUDA device with 173.14.09

uname -a
Linux michael7 2.6.24-1-amd64 #1 SMP Sat May 10 09:28:10 UTC 2008 x86_64 GNU/Linux

No installed any ‘Xen’ versions of kernel. All OpenGL applications works normally.

I’m not clear how you determined that CUDA only works with 169.09, as that is definitely not true.

If this problem persists with 177.13, please generate and attach an nvidia-bug-report.log, and confirm that you’ve installed the 32bit compatibility packages that ship with the OS.

I tried suggestion, there is no problem with 177.13: a CUDA device found and CUDA programs works properly. So, may be this is only 173.14.09 bug.

177.13 replaces all older drivers.