no CUDA-capable device is detected

Hi !!

I am trying to execute GPU applications on one of the server:
OS: OpenSuse 12.3 x86_64 3.7.10-1.1-desktop (Kernel Release)
gcc: 4.7.2

First, I have downloaded and installed the latest driver.
DRIVER NVIDIA-Linux-x86_64-310.40.run

Then, Installed the CUDA 5.0 (samples and toolkit), instructions available at http://svshift.blogspot.in/2013/03/running-nvidai-cuda-sdk-50-on-opensuse.html

Then, I checked my cuda installation.
Added Library paths
#CUDA-5.0
export CUDA_HOME=/usr/local/cuda-5.0
export PATH=$CUDA_HOME/bin:$PATH
export LD_LIBRARY_PATH=$CUDA_HOME/lib64:/lib:$LD_LIBRARY_PATH

Complied and executed deviceQuery utility (/root/NVIDIA_CUDA-5.0_Samples/1_Utilities/deviceQuery). Its output is attached.

Also execute nvidia-smi :
±-----------------------------------------------------+
| NVIDIA-SMI 4.310.40 Driver Version: 310.40 |
|-------------------------------±---------------------±---------------------+
| GPU Name | Bus-Id Disp. | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 NVS 300 | 0000:03:00.0 N/A | N/A |
| N/A 49C N/A N/A / N/A | 3% 16MB / 511MB | N/A Default |
±------------------------------±---------------------±---------------------+
| 1 Tesla K20c | 0000:04:00.0 Off | Off |
| 30% 38C P8 16W / 225W | 0% 13MB / 5119MB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Compute processes: GPU Memory |
| GPU PID Process name Usage |
|=============================================================================|
| 0 Not Supported |
±----------------------------------------------------------------------------+

Now, I tried to run the applications VMD and GROMACS
VMD 1.9.1
The error messages are:
Info) Free system memory: 63762MB (98%)
Warning) Detected a mismatch between CUDA runtime and GPU driver
Warning) Check to make sure that GPU drivers are up to date.
Info) No CUDA accelerator devices available.
Warning) Detected X11 ‘Composite’ extension: if incorrect display occurs
Warning) try disabling this optional X server feature.
Info) OpenGL renderer: Quadro 600/PCIe/SSE2
Info) Features: STENCIL MSAA(16) MDE MTX NPOT PP PS GLSL(OVFG)
XRequest.135: BadLength (poly request too large or internal Xlib length error) 0x9a00009
Warning) GPU driver failed to compile shader:
Warning) /usr/local/lib/vmd/shaders/vmd
Warning) This GPU/driver is buggy, or doesn’t fully implement GLSL.
Warning) Set environment variable VMDGLSLVERBOSE for more info.

GROMACS 4.6.1
NOTE: Error occurred during GPU detection:
no CUDA-capable device is detected
Can not use GPU acceleration, will fall back to CPU kernels.

Will use 24 particle-particle and 8 PME only nodes
This is a guess, check the performance at the end of the log file
Using 32 MPI threads

No GPUs detected

According to the gromacs mailing list the above message is returned by libcudart.

Am I missing somthing or have done something wrong, due to which the applications are not able to find GPUs. Kindly suggest me.

deviceQuery.txt (3.88 KB)

The Gromacs’s problem of not recognizing the GPU is solved by changing the permission of /dev/nvidia* files to 0666.