No HDMI audio with cinema amp - custom modeline - how to override EDID but let ELD data through?

Hi all,

I am trying to get HDMI audio working. Using 304.64 / Debian Wheezy, but I don’t think this is technically a driver issue (read on to see what it is :) ).

My PC HDMI output goes to a Yamaha DSP-AX761 home cinema amp, and from there HDMI -> DVI to a Sanyo PLV-Z2 projector. There is an EDID problem with the projector, so I set a custom modeline in xorg.conf, and UseEDID “False”.

This has worked great until I have tried to get HDMI audio working. It was frustrating me for months, then I read ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html#_verify_your_eld_is_valid which explained a lot. Unfortunately all I have in cat /proc/asound/card1/eld#3.0 is:
monitor_present 0
eld_valid 0

I’m guessing that this is because I use UseEDID “False” and no ELD information gets reported to ALSA. Is there any way that I can tell the driver to only ignore the modeline part of the EDID, but to use the audio part?

That of course assumes that the audio part will be sane, but surely something is better than nothing for starters.

Grateful for any help from the EDID / ELD gurus around here, thanks.

I tried to attach my nvidia-bug-report.log.gz to this post - if it doesn’t work, you can see it at https://docs.google.com/file/d/0B-IMV9hxPWRBUnhEcm1qNHgxNXM/edit?usp=sharing
nvidia-bug-report.log.gz (46.4 KB)