No HDMI output using HDMI to VGA converter

Hi all,
since the update to L4T v24.1 I have no HDMI output using a HDMI to VGA converter.

Any ideas to verify what’s happening?

I can correctly connect to TX1 using SSH

Thank you

Walter

Older VGA is not supported. Basically anything newer than the 15-pin D-sub has an extra wire for the video to query the monitor and ask it about its specs. There can be no automated setup of correct details without that wire.

You do have the option to manually create a config file for your monitor, but this is a lot of work. Basically you’d be manually creating everything, even mode lines. See:
https://en.wikipedia.org/wiki/XFree86_Modeline

I’m having a similar problem,

  • HDMI to VGA converter is connected to Jetson Tx1 but it gives no display output on VGA monitor.
  • But when connected to a HDMI TV without any adaptors it gives the output.
  • HDMI to VGA converter works properly on Raspberry pi3 and laptop
  • Since XDRP installed on Jetson Tx1 I have access to the board's remote desktop (installed by plugging it to the TV)
    1. I have got the edid file from the Raspberry pi3 for the HDMI to VGA adaptor. If I replace the edid file inside Jetson Tx1 with this. Will it work?
    2. When I try to copy edid file I got from raspberry pi to the relevant folder (/sys/kernel/debug/tegradc.1/) It says permission denied (even logged as root user) How to give permission to do this file operation?

    Thank you

    VGA is unsupported. All monitor types after VGA added an extra wire which allows the video card to query the monitor and ask it what its capabilities are. This is how auto configuration works. Cutting that wire (the DDC/EDID wire) removes all automatic configuration. Should default video mode coincide with something the monitor works with you’re in luck (your RPi uses a different default resolution than the Jetson…Jetsons should probably use a standard default resolution of 640x480).

    Providing an xorg.conf which reflects the monitor abilities would do the job (not easy, it is a steep learning curve and research). Providing an EDID response (equivalent to the xorg.conf) would do the job, but I’m not familiar with writing to the EDID file (you could “sudo chmod u+w /sys/where/ever/it/is/edid”, but this file may be a reflection of what the system uses and not a source of what determines anything…even if the file is used as a data source changes to the file may not notify anything else to reload). Normally you would paste your EDID into http://www.edidreader.com and use that to study while figuring out how to edit xorg.conf.

    Editing the xorg.conf was unsuccessful for me.

    I have used an another HDMI to VGA converter (same type) and it worked well on Jetson TX1 development board. But the adapters which are not working on Jetson TX1 development board are working properly on a laptop, Raspberry Pi, even on Jetson TX1 with carrier board. Only the problem comes with the development board. Hence I assume it could be a hardware bug on Jetson TX1 development board.

    This is the type of adapter I have used,

    http://www.ebay.com/itm/1080P-HDMI-Male-to-VGA-Audio-Video-Converter-Adapter-Cable-for-PC-Laptop-TV-LCD-/141691439688?hash=item20fd77ca48:g:llwAAOSw5ZBWPN1D

    I have used 3 adaptors and only one of them worked. Worked one was an old adapter purchased some time ago. Newly purchased ones didn’t work. Does this issue have any connection with the HDMI versions?

    But all adapters work fine with the Jetson TX1 on the carrier board. Hence I think HDMI versions couldn’t be an issue.

    Unless the adapter fills in EDID information specific to your monitor you will still be depending on luck to hit a default mode the monitor supports. One thing you might do to get extra mode logging information into the “/var/log/xorg.0.log” file is to add this at the end of the “Device” section of “/etc/X11/xorg.conf”:

    Option    "ModeDebug"
    

    After booting up look at “/var/log/Xorg.0.log” and see if EDID modes are seen and accepted or rejected.