No such element or plugin 'nvoverlaysink' in deepstream 6.1

Hi,
When I was trying to use nvoverlaysink plugin in my pipeline, I get this error:
WARNING: erroneous pipeline: no element “nvoverlaysink”

when I checked if it exists or not using gst-inspect-1.0:

gst-inspect-1.0 nvoverlaysink
No such element or plugin ‘nvoverlaysink’

Is the nvoverlaysink is removed from deepstream 6.1?
If it is removed, is there any alternative for it ?

• Hardware Platform (Jetson AGX Orin)
• DeepStream Version 6.1
• JetPack Version 5.0.1
• TensorRT Version 8.4.0.11

Please use nvdrmvideosink or nveglglesksink, suggest use the first one on Jetson, the second will take GPU usage.

Is there a way to integrate nvoverlaysink into deepstream 6.1 ?

The nvoverlaysink plugin is deprecated in L4T release 32.1. Please use nvdrmvideosink or nv3dsink for rendering gst-v4l2 decoder output.

Is there an example code that uses nvdrmvideosink or nv3dsink plugin ?

I tried to run:
gst-launch-1.0 filesrc location=<filename.mp4> ! qtdemux name=demux ! h264parse ! omxh264dec ! nvdrmvideosink -e

and I got the following error:
WARNING: erroneous pipeline: no element “omxh264dec”

One example to use nvdrmvideosink, you need to disable X, by sudo systemctl set-default multi-user.target, reboot the device.
gst-launch-1.0 filesrc location= /opt/nvidia/deepstream/deepstream/samples/streams/sample_1080p_h264.mp4 ! qtdemux ! h264parse ! nvv4l2decoder ! m.sink_0 nvstreammux name=m width=1920 height=1080 batch-size=1 ! nvinfer config-file-path= /opt/nvidia/deepstream/deepstream/samples/configs/deepstream-app/config_infer_primary.txt ! ‘video/x-raw(memory:NVMM), format=(string)NV12’ ! nvdrmvideosink conn_id=1 plane_id=0 set_mode=0

@Amycao
After Running:

sudo systemctl set-default multi-user.target
sudo reboot

The Orin doesn’t show any screen or terminal as if it is closed. I accessed it using SSH, then run your command:

gst-launch-1.0 filesrc location= /opt/nvidia/deepstream/deepstream/samples/streams/sample_1080p_h264.mp4 ! qtdemux ! h264parse ! nvv4l2decoder ! m.sink_0 nvstreammux name=m width=1920 height=1080 batch-size=1 ! nvinfer config-file-path= /opt/nvidia/deepstream/deepstream/samples/configs/deepstream-app/config_infer_primary.txt ! ‘video/x-raw(memory:NVMM), format=(string)NV12’ ! nvdrmvideosink conn_id=1 plane_id=0 set_mode=0

it outputs:

I used nvstart-weston.sh to open DRM then run the command again. it outputs:

Any Ideas ?

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Change to conn_id=1 and try again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Did this still be an issue?
For orin, you need to install nvidia-drm driver by sudo modprobe nvidia-drm modeset=1

1 Like