No such element or plugin 'nvv4l2vp8enc'

Please provide complete information as applicable to your setup.

• Hardware Platform (GPU, Ubuntu 18.04)
• DeepStream-5.1
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (465.19.01)
• Issue Type(No such element or plugin ‘nvv4l2vp8enc’ )
• CUDA version (11.3)

I was trying to use graphic carte to accelerate my trancoding pipeline h264 → vp8. To decode h264 stream we got nvv4l2decoder who works effciently. To encode the stream to vp8 I’ve saw in somewhere someone using nvv4l2vp8enc, but when i input ‘gst-inspect-1.0 nvv4l2h264enc’ in terminal it gives error ‘No such element or plugin ‘nvv4l2vp8enc’’. Could anyone tell me if NVENC supports the vp8 encod or it depends on which plateform I use (Jetson/dGPU)? Or even NVENV dosen’t actually supports vp8 enc?

Thanks.

Which GPU are you working on?

Please refer to the document Gst-nvvideo4linux2 — DeepStream 6.0 Release documentation

Thanks to your response Fiona. My GPU is RTX 2080 Rev.

We don’t provide any HW encoder for vp8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.