Not able to play sample_720p video not use it in while running Deepstream sample

Hi ,

currently i am trying to install and test Deepstream on my TX2 . i am currently facing some issue with playing the sample_720p.mp4 through Videos app . the videos app lust outputs a black screen when tried to play .

Running nvgstiva-app -c ${HOME}/configs/PGIE-FP16-CarType-CarMake-CarColor.txt -i ~/sample_720p.mp4 cmd resulted in the following error message

Error from qtdemux0: GStreamer encountered a general stream error.
Debug info: qtdemux.c(5520): gst_qtdemux_loop (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstURIDecodeBin:src_elem/GstDecodeBin:decodebin0/GstQTDemux:qtdemux0:
streaming stopped, reason not-linked

<a target='_blank' rel='noopener noreferrer' href=''></a>

also this error

** INFO: <bus_callback:138>: Pipeline ready

Error from src_elem: Your GStreamer installation is missing a plug-in.
Debug info: gsturidecodebin.c(1006): no_more_pads_full (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstURIDecodeBin:src_elem:
no suitable plugins found:
gstdecodebin2.c(4565): gst_decode_bin_expose (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstURIDecodeBin:src_elem/GstDecodeBin:decodebin0:
no suitable plugins found:
Missing decoder: H.264 (High Profile) (video/x-h264, stream-format=(string)avc, alignment=(string)au, level=(string)3.1, profile=(string)high, codec_data=(buffer)0164001fffe1001a6764001facd9405005bb0110000003001000000303c0f183196001000668ebe3cb22c0, max-input-size=(int)170873, width=(int)1280, height=(int)720, framerate=(fraction)30/1, pixel-aspect-ratio=(fraction)1/1)

issue with playing sample_720p.mp4 using Videos app started only after i followed this post to install opencv3 for python3 https://jkjung-avt.github.io/opencv3-on-tx2/ . am i missing any decode ?

how to reinstall gstream without flashing TX2

Thanks
yuvaram

issue solved for Deepstream

i remove and reinstalled Gstreamer following this document

Now the Deepstream sample works fine
nvgstiva-app -c ${HOME}/configs/PGIE-FP16-CarType-CarMake-CarColor.txt -i ~/sample_720p.mp4

still having issue with playing videos through ubuntu apps (videos,vlc)

Hi,
We do not support HW acceleration on ubuntu apps. You probably can check if you install SW decoders such as ffmpeg.

thank you . will check for ffmpeg installation .