Nov 3 version 455.28 update: driver stops working on Linux Mint 20 Cinnamon

Hello, Linux driver team! Yesterday, a new update came from the nvidia-drivers PPA and the following files were installed on my PC:

Commit Log for Tue Nov  3 17:41:07 2020

Upgraded the following packages:
accountsservice (0.6.55-0ubuntu12~20.04.2) to 0.6.55-0ubuntu12~20.04.4
gir1.2-accountsservice-1.0 (0.6.55-0ubuntu12~20.04.2) to 0.6.55-0ubuntu12~20.04.4
libaccountsservice0 (0.6.55-0ubuntu12~20.04.2) to 0.6.55-0ubuntu12~20.04.4
libnvidia-cfg1-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-common-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-compute-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-compute-455:i386 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-decode-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-decode-455:i386 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-encode-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-encode-455:i386 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-extra-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-fbc1-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-fbc1-455:i386 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-gl-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-gl-455:i386 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-ifr1-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
libnvidia-ifr1-455:i386 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
nvidia-compute-utils-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
nvidia-dkms-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
nvidia-driver-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
nvidia-kernel-common-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
nvidia-kernel-source-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
nvidia-utils-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1
python3-cryptography (2.8-3) to 2.8-3ubuntu0.1
xserver-xorg-video-nvidia-455 (455.23.04-0ubuntu0~0.20.04.1) to 455.28-0ubuntu0~0.20.04.1

After rebooting, the driver no longer works:
https : //pasteboard.co/JyLMKS2.png

(sorry about the spaces in the URL, otherwise it won’t display in the post, I noticed).

I solved the issue by switching to version 450. I switched back to 455 once more to see if the problem was reproducible, and it is.

That said, the issue does not occur on my laptop PC, which also has Linux Mint 20 Cinnamon installed. It has an RTX 2070 (TU106M [GeForce RTX 2070 Mobile]). My desktop PC, the affected one, has a GTX 1080 Ti.

The specs of the affected PC:
https://termbin.com/wazv

The specs of my laptop PC for comparison:
https://termbin.com/l3lax

I’m posting this here in case you wanna look into this issue. Since I’m using this PC for work, I need to stay on 450 throughout the day, but if you need any further info, I can switch to 455.28 again tonight and collect it.

Hey again, I just created the log file. It’s attached. Note that I was not able to run the server as follows:

startx -- -logverbose 6

I pressed Ctrl+Alt+F2, logged in and typed the command, but no GUI came up. I only got this:
(upload://fDFsXxBod7U2IhZV57wpd7Ptl8x.gz) (758.6 KB) https : //pasteboard.co/JyM5hUB.png

So I ran the bug report script from my normal desktop that came up after booting regularly. I’m hoping you can find useful information in the log anyway.

[nvidia-bug-report.log.gz|attachment]

Hey again, it seems like the upload of the attachment didn’t work, I’m only seeing references to the file in my above post, but not the file itself. So I put the log on my Google Drive for you.

Or on Dropbox, if you prefer: