Nsight 4.7 - A problem caused to program stop working correctly...

I am dealing with an unfimiliar problem when i try to debug my CUDA code with Nsight.
I am getting the following message:

"programname.exe has stopped working
A problem caused the program to stop working correctly. Windows will close the program and notify you if
a solution is available. "

After reading other topics i tried to perform performance analaysis (Trace on CUDA domain) but it couldn’t finish. Again it crashed with the same message.

Information about my system:
Windows 10
Two GPUs: Tesla K20c and NVS 315.
Visual studio 2012
CUDA version 7.5

Steps that were taken:
Switching between compute_20 sm_20 and compute_30 sm_30.
If i run the code in local windows debugger it would run perfectly
(but still need to debug it in kernel level).

Looking for log file that may be created by Nsight but nothing new was under the path C:\Users\David Leon\AppData\Roaming\NVIDIA Corporation\Nsight\Monitor\1.0\Logs

Trying the same code on another computer with Nsight 4.5 and CUDA 7.0 and Nsight works.
The other machine’s GPUs: GTX 660 and GTX 750 Ti

Any suggestions for steps that i should take?
Thanks in advance

Hi,

What kind of your application is? Is it a graphics interop application? I’m afraid your application is running on NVS 315. It’s a Fermi arch. But you build your project to sm_30. Then you may encounter such error. If your application is not a graphics interop one, you may try to set env CUDA_VISIBLE_DEVICES as 0 or 1 to point to Tesla K20c. Then launch Nsight Monitor and try Cuda debugger or analysis again. If it’s an interop application, it must run on non-Tesla card. So you need to build it with sm_20 and run it on NVS 315. Tell me whether this works for you. Thanks.

Qian

The application performs calcultaions on two dimensional array (that was flatted).
Just a conventional project in CUDA without any graphics.

I built my project originaly to sm_20 but saw in some of the topics that changing to sm_30
may solve some problems.
I also went to Nvidia control panel -> 3dSettings -> global settings -> CUDA Units and selected Tesla K20c to
be the only GPU for CUDA.

The application performs calcultaions on two dimensional array (that was flatted).
Just a conventional project in CUDA without any graphics.

I built my project originaly to sm_20 but saw in some of the topics that changing to sm_30
may solve some problems.
I also went to Nvidia control panel -> 3dSettings -> global settings -> CUDA Units and selected Tesla K20c to
be the only GPU for CUDA.

What’s your driver version? You could see it in Nvidia control panel -> Home button. Is it possible for us to get your application? If it’s a small project, may you zip it and send to qzhang@nvidia.com? Thanks.

The version is 353.90

About the application, it performs calcultaions on two dimensional array (that was flatted).
Just a conventional project in CUDA without any graphics.

I built my project originaly to sm_20 but saw in some of the topics that changing to sm_30
may solve some problems.
I also went to Nvidia control panel -> 3dSettings -> global settings -> CUDA Units and selected Tesla K20c to
be the only GPU for CUDA.

print screen of the problem

https://drive.google.com/file/d/0ByOtMTLCoUHOV1ZPU1pFaVMzZU0/view?usp=sharing

I would ask for permission from my superior to send the application.
Thank in advance for your help and your attention.

It is a bit strange since part of time it runs and part of time falls.