Nsight Compute initialization error

Hi,

When using Nsight Compute integration in Visual Studio my program crashes, without it the program runs just fine. When using Nsight Compute, optixInit returns 7990 which corresponds to OPTIX_ERROR_INTERNAL_ERROR. I have just now re-installed all Nvidia drivers, CUDA, and OptiX but this did not alleviate the issue. The versions of the software I am using are:

CUDA 11.3
Graphics Driver 466.47
Nsight Compute 2021.1.1
Nsight Systems 2021.1.3
Nsight Visual Studio Edition 2021.1.1.21111
OptiX 7.3.0

I hope someone can help me with this problem.

EDIT: I am using an RTX 2070.
EDIT 2: Reinstalling Visual Studio also did not help.

Hi, thanks for the report, I will attempt to reproduce this and then file a bug report. Which menu item are you using to Launch Nsight VSE debugging? (There are a couple of them, IIRC, aren’t there?) Also is Nsight Systems working for you in this configuration?

There are a couple of things you could try just to see if the cause can be narrowed down:

  • Try using CUDA 11.1. Since this is the version OptiX 7.3 was released against, it is possible that CUDA 11.3 is causing the issue.

  • Try using Nsight VSE on the OptiX SDK samples, to rule out something specific with your application. If it also breaks on the OptiX SDK samples, that would tend to place even more blame on a bug on our side.

  • Try using an older version of Nsight Compute & VSE, and/or older driver as a last resort (there are only a few Windows 465+ drivers to choose from, but if nothing else works, might be worth checking that it’s not a bug in the most recent driver.)


David.

Hi, thanks for your reply. The menu item I am using is “Profile” (the other option is “Interactive Profile”). I leave all settings/options within the Nsight Compute menu on default.

I am not familiar with Nsight Systems, but selecting “Trace” and then my target (my PC) and clicking “Start” while leaving all options on default seems to work just fine.

I also get a crash when using the SDK samples. I used “optixPathTracer”, which works fine when using just Visual Studio when I am not using Nsight Compute. I am not sure what the error message is, as the command window closes too quickly.

I will now try using a different CUDA version.

Deinstalling all CUDA 11.3 related programs, rebooting, installing CUDA 11.1 fixed my issue. Both the samples and my own application are profilable with Nsight Compute now.

Installing CUDA 11.1 seems to also have rolled back the Nsight Compute version to 2020.2.1, and it has also installed Nsight Systems 2020.3.4 (I now have two versions). All other version number remain the same as in the original post. I am quite unclear between the relation of CUDA, Nsight Compute and Nsight VSE versions, but this particular configuration seems to work for me.

1 Like

Thanks for confirming, I’m really glad you got it working, and it’s helpful to hear that CUDA 11.3 was causing the problem. I’ll post back if/when I hear that OptiX is made compatible with CUDA 11.3, if that happens before the next OptiX SDK release.


David.