NSIGHT ERROR on JETSON XAVIER: "Application received signal 139" when profiling a simple application

Dear All,

I have a host machine that runs Ubuntu 18.04 LTS natively and remotely connects to Jetson Xavier. When I execute a simple CUDA program, it runs fine, but when I attempt to do visual profiling I get some version of the following error:

“Application received signal”
“Application received signal 139”

The entire program is aborted and I’m left with no profiling graphs or data.

In the remote debugging settings, upload the executable to Jetson Xavier and run the program.

The program simply prints “Hello CPU” from the main() function, and “Hello GPU” from a CUDA kernel (using a global function).

Some observations:

  • If I take out the CUDA kernel and cudaDeviceReset(), I am able to profile with no problem. It shows CPU profiling data and graphs.

  • If I take out only cudaDeviceReset(), the program doesn’t even recognize the CUDA kernel. It shows CPU profiling data and graphs.

  • I’ve tried checking and unchecking “Enable concurrent kernel profiling” but that doesn’t change anything

  • I’ve tried checking and unchecking “Start application with profiling enabled” but that doesn’t change anything.

  • I’ve tried checking and unchecking the “Unified memory” setting but that doesn’t change anything.

There is talk of a segmentation fault. There is also talk of it being a combination of two errors (11 + 128), but no real information on how to go about resolving them.

I really need to be able to profile my applications, especially the GPU side of the equation. Any help would be appreciated.

-Cuda Education
cudaeducation.com

Hi,

Have you installed the CUDA host toolkit from the JetPack?

The package includes some required libraries for cross-compiler.
These libraries may not be available for the one downloaded from the website.

Thanks.

I installed everything from the JetPack when flashing and setting up the Jetson Xavier Developer Kit. I’ve done it several times, so I’m very familiar the process.

What I will do is create a video showing you how I go about profiling and post it to YouTube with a link here. Maybe that will be more helpful in diagnosing the problem.

Thank you for your efforts in the matter.

-Cuda Education
cudaeducation.com

Here is a YouTube link to the video that shows what’s happening on my system more clearly:

https://youtu.be/P350PpeZnc0

Here are some extra details on my setup:

Host Machine
Ubuntu 18.04 LTS (native installation)
Nsight Eclipse Edition (installed with JetPack 4.1.1)

Remote Machine
Jetson Xavier Developer Kit

Thanks for your help everyone!

-Cuda Education
cudaeducation.com

Hi,

Thanks for your update.
We will try to reproduce this internally and update information with you later.

Just as additional information. If I try to run multiple CUDA kernels in my code, I get an error message "segmentation fault (core dumped) error message. I can make a video showing this problem also, but it might be a separate issue and I don’t want to confuse the situation.

Thanks again for your help.

-Cuda Education
cudaeducation.com

Hi,

We are still checking this issue internally.
Will update Infomation with you once we got some progress.

Thanks.

Thank you!

Let me know if you need anything else.

-Cuda Education
cudaeducation.com

[EDIT] Running nvprof with sudo fixed the issue.

I face the same issue as well.

I tried profiling the sample bandwidthTest provided by CUDA-10, but I keep seeing:

“======== Error: Application received signal 139”

Hi, both

Sorry for keeping you waiting.
The signal 139 issue is fixed in the CUDA-10.1.88 internally.

This CUDA version is not available for Xavier yet.
Please wait for our announcement for the next JetPack release.

Thanks.