Nsight System Communication Error

Hi,

I have some problems to get Nsight System 2024.1.1 working:

It makes no difference if I start Nsight system from the commandline or from VS2022 (all updates). When it start I can select a target - I select the localhost since I use a single machine for the development:
Screenshot 2024-02-05 085310

After some seconds (maybe 30) I getan error message telling me that there is some kind of communication error:

Clicking on ‘More info…’ gives me this:
Screenshot 2024-02-05 085411

Clicking on ‘More info…’ again brings up this window:

SSH-server is installed:

I then start Nisight system again to create a logfile with these commands:

set NVLOG_CONFIG_FILE=C:\Program Files\NVIDIA Corporation\Nsight Systems 2024.1.1\host-windows-x64\nvlog.config.template
“C:\Program Files\NVIDIA Corporation\Nsight Systems 2024.1.1\host-windows-x64\nsys-ui.exe”

I attach the created logfile to this mail.

Hope someone can help. Thanks.
nsys-ui.log (29.4 KB)

Quick question, and then I’ll pass you along to an Nsys Windows expert (I mostly focus on Linux). Are you running Nsys with administrator privledges?

Hi,

I run VS2022 as Admin when I start NSight System through VS. If I start Nsight system from commandline I run it as regular user - not as Admin.

Okay, I think you do want to have a command window with administrator privledges to run the CLI.

I’m going to loop in Doron, who’s the Windows Nsys owner.

@dofek

Hi,
I tried to run Nsight System as with Administrator permissions, but the results are the same. It stops with a communication error -same as running as regular user.

Hi,

Is there anything I can do to help finding the problem? Do you need more or different logfiles or screenshots? More information about my environment?

Thanks

You can follow the directions on logging on Windows at User Guide — nsight-systems 2024.1 documentation (I promise, that is an exact link, this forum software won’t let me alter the text is selects).

I’ll directly slack Doron to respond to this, but as he is in Israel, he probably will not respond before Sunday.

Hi,

thanks for the update - looking forward to get this fixed.

Thanks.

Hi TrailingStop,
I see the user name logged into the machine consists of two words separated by a space character. I suspect this might be related to the crash.
Can you try to use Nsight Systems on an account whose name does not contains spaces?
Doron

Hi, yes, will give it a try

Hi,

I created a new single ‘word’ user on my PC and retried nvidia systems. Same problem. Communication error.

Anything else I can try?

Happy to share my PC for you to debug the problem.

Here are the conclusions from an investigation session on TrailingStop’s workstation:

  1. Nsight Systems host application (nsys-ui) fails to run when the logged-in account name contains space characters. This is a bug and I will add it to the backlog for fixing.
  2. Launching Nsight Systems from the Visual Studio integration Nsight menu overcomes this problem and nsys-ui runs successfully. However, it fails to connect to the local nsys agent process. This is what the original post described.
  3. The nsys CLI performs correctly and is not affected by the space characters in the logged-in user account name.

Doron