NV Visual Profiler: No GPU devices in session

I previously used NV Visual Profiler with CUDA 5.0 to view the GPU usage of the OptiX application I’m working on. Now that I’ve upgraded to CUDA 6.0 and am using the version of NVVP that comes with it, I can no longer see entries for my GPUs in the timeline. Instead, I only see entries for the Runtime API, Driver API, and Profiling Overhead. The timeline also stops early, usually after a few seconds or milliseconds.

In the Analysis tab, I see a message saying “No GPU devices in session, GPU usage analysis cannot be performed.”

I have the same problem with many (though not all) of the CUDA Samples.

Any ideas how to fix this? I’m running Windows 7 and have tried 32-bit and 64-bit versions of my program.

I have a semi-similar problem with the nvprof command line profiler under Windows 7. I filed a bug report.

Running "nvprof " will not capture any profiling results.

Running “nvprof .exe” will properly capture profiling results.

My problem doesn’t seem related to the extension. I have “.exe” included in all cases.

I tried using nvprof from the command line. It shows me results for the API calls, but tells me “No kernels were profiled.”

maybe your kernel launches are failing. What happens if you run your app with cuda-memcheck?
Also, maybe your CUDA setup is now broken. What happens if you run

nvidia-smi -a

?

What is the output of running the deviceQuery sample app?

My program does generate an output image, which leads me to believe that the kernel launch is not failing. nvidia-smi -a shows the output I would expect for both of the machines I’ve tried this on (one with a Quadro K4000, one with two Tesla K40s).

Since you asked, here’s the output from deviceQuery:

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "Quadro K4000"
  CUDA Driver Version / Runtime Version          6.0 / 6.0
  CUDA Capability Major/Minor version number:    3.0
  Total amount of global memory:                 3072 MBytes (3221225472 bytes)
  ( 4) Multiprocessors, (192) CUDA Cores/MP:     768 CUDA Cores
  GPU Clock rate:                                811 MHz (0.81 GHz)
  Memory Clock rate:                             2808 Mhz
  Memory Bus Width:                              192-bit
  L2 Cache Size:                                 393216 bytes
  Maximum Texture Dimension Size (x,y,z)         1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
  Maximum Layered 1D Texture Size, (num) layers  1D=(16384), 2048 layers
  Maximum Layered 2D Texture Size, (num) layers  2D=(16384, 16384), 2048 layers
  Total amount of constant memory:               65536 bytes
  Total amount of shared memory per block:       49152 bytes
  Total number of registers available per block: 65536
  Warp size:                                     32
  Maximum number of threads per multiprocessor:  2048
  Maximum number of threads per block:           1024
  Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
  Max dimension size of a grid size    (x,y,z): (2147483647, 65535, 65535)
  Maximum memory pitch:                          2147483647 bytes
  Texture alignment:                             512 bytes
  Concurrent copy and kernel execution:          Yes with 1 copy engine(s)
  Run time limit on kernels:                     Yes
  Integrated GPU sharing Host Memory:            No
  Support host page-locked memory mapping:       Yes
  Alignment requirement for Surfaces:            Yes
  Device has ECC support:                        Disabled
  CUDA Device Driver Mode (TCC or WDDM):         WDDM (Windows Display Driver Model)
  Device supports Unified Addressing (UVA):      Yes
  Device PCI Bus ID / PCI location ID:           1 / 0
  Compute Mode:
     < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.0, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = Quadro
K4000
Result = PASS

Hello,when I use the profiler ,I also have the same problem,so I would like to know if you have fixed it ? Thanks

What is the output of nvidia-smi -a ?

specifically, what is the compute mode set to?

I have find the solution for this problem,you just need to add the function cudaProfilerStop() behind your program.Don’t forget the head file #include <cuda_profiler_api.h>

I have found why! Before using visual Profiler to analyse project, you should add two functions before codes which execute in kernel function and after: cudaProfilerStart(); and cudaProfilerStop().