Nv3dsink seems not play video with source stream fps

Please provide complete information as applicable to your setup.

• Hardware Platform Jetson
• DeepStream Version 6.3
• JetPack Version (valid for Jetson only) 5.1.2
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)

I set multiple local mp4 file as input. Each mp4 is 25 fps, after I run these mp4 files with deepstream and set the output with nv3dsink. The issue is the output stream play with different fps. (I have enabled sync: 1 for nv3dsink). I want to know how do I control this time synchrnization? And is this synchronization only occured for sink display? Will it impact infer and mqtt broker?

which sample are you testing or referring to? can you try one source to check if fps is fine? I can’t reproduce this issue On Orin with DS7.0 by source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.yml without any modification. Here is the log log-611.txt (1.7 KB)

My problem, I set drop-frame parameter, which cause the sync issue. It is solved now.