Nvargus crashes when accessing camera

I am trying to run the following on a jetson orion nano with jetpack 5.1.2. Running the same code on a jetson nano with jetpack 4.6.1 worked fine. For both i am useing a arducam IMX477

running: v4l2_open(dev.name, O_RDWR) , where dev.name, is /dev/video0 , gives the following crash:

(Argus) Error EndOfFile: Unexpected error in reading socket (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 277)

(Argus) Error EndOfFile: Receive worker failure, notifying 1 waiting threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 350)

(Argus) Error InvalidState: Argus client is exiting with 1 outstanding client threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 366)

(Argus) Error EndOfFile: Receiving thread terminated with error (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadWrapper(), line 379)

(Argus) Error EndOfFile: Client thread received an error from socket (in src/rpc/socket/client/ClientSocketManager.cpp, function send(), line 145)

(Argus) Error EndOfFile: (propagating from src/rpc/socket/client/SocketClientDispatch.cpp, function dispatch(), line 91)

ArgusV4L2_Open failed: No such file or directory

nvbufsurftransform:cuInit failed : 999

Segmentation fault (core dumped).

I have checked if /dev/video0 has any issues through: v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap --stream-count=10 -d /dev/video0 --verbose , which shows that the communication with the camera is ok.
Running gst-launch-1.0 nvarguscamerasrc ! "video/x-raw(memory:NVMM),width=4032,height=3040,framerate=30/1,format=NV12” ! nvvidconv “video/x-raw, format=BGRx” ! fpsdisplaysink video-sink=fakesink text-overlay=false sync=false -v on the other hand gives similar error as above. I get this error every time i try to run the code and have tried restarting the nvargus daemon, but this has not helped.
Any help would be much appreciated!

Please run the command and see if it works:

$ gst-launch-1.0 nvarguscamerasrc ! fakesink

If sensor driver and device tree are ready, the command should be running fine without error.

This command gives me the following:
*GStreamer-WARNING *: 11:03:50.506: Failed to load plugin ‘/usr/lib/aarch64-linux-gnu/gstreamer-1.0/libgstnvarguscamerasrc.so’: /usr/lib/aarch64-linux-gnu/tegra/libnvcam_imageencoder.so: undefined symbol: jpeg_set_defaults
WARNING: erroneous pipeline: no element “nvarguscamerasrc”


The lib should be in default system. Please confirm if it is present. If not, we would suggest re-flash the system through SDKManager.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.