Nvbuf_utils: Could not get EGL display connection

Hi,

I try to run the following example on my Jetson nano production module:
https://docs.nvidia.com/jetson/l4t-multimedia/l4t_mm_00_video_decode.html
Unfortunately the following errors occurred when I execute the following:

chris@chris-desktop:/usr/src/jetson_multimedia_api/samples/00_video_decode$ ./video_decode H264 ./test.h264
No protocol specified
nvbuf_utils: Could not get EGL display connection
Set governor to performance before enabling profiler
Creating decoder in blocking mode 
Opening in BLOCKING MODE 
Error opening input file
App run failed

The Jetson nano is connected to two cameras that are listed below:

chris@chris-desktop:/usr/src/jetson_multimedia_api/samples/00_video_decode$ v4l2-ctl --list-devices
vi-output, vc_mipi 6-001a (platform:54080000.vi:0):
	/dev/video0

vi-output, vc_mipi 0-001a (platform:54080000.vi:2):
	/dev/video1

What am I doing wrong? Did anybody had the same error?

Hi,
The sample uses NvEglRenderer and you would need to set $ export DISPLAY=:0(or 1). Please set this and give it a try.

Hi,
I set the environment variable DISPLAY=:1 and the protocol error is fixed. But have received another error:

chris@chris-desktop:/usr/src/jetson_multimedia_api/samples/00_video_decode$ export DISPLAY=:1
chris@chris-desktop:/usr/src/jetson_multimedia_api/samples/00_video_decode$ ./video_decode H264 ./test.h264
Set governor to performance before enabling profiler
Creating decoder in blocking mode 
Opening in BLOCKING MODE 
Error opening input file
App run failed
chris@chris-desktop:/usr/src/jetson_multimedia_api/samples/00_video_decode$ 

I tried to solve it by installing the following but the error still occurs

sudo apt-get install cpufrequtils
echo 'GOVERNOR="performance"' | sudo tee /etc/default/cpufrequtils
sudo systemctl disable ondemand

What am I doing still wrong?

Hi,

It looks like the path to the file is not correct.

Hi,
thank you for your help. It works, the path was not correct.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.