nvcc: cannot execute binary file: Exec format error

I believe my error comes from not organize paths correctly. I need help on fixing so that nvcc works correctly. SEE BELOW FOR DETAILS, THANK YOU.

When I run nvcc --version, this output:
bash: /usr/local/cuda-9.0/bin/nvcc: cannot execute binary file: Exec format error

MY BASHRC LOOK LIKE THIS:
export PATH=/usr/local/cuda-9.0/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin:/usr/local/cuda/bin${LD_LIBRARY_PATH:+:{LD_LIBRARY_PATH}} export LD_LIBRARY_PATH=/usr/local/cuda-9.0/lib64\${LD_LIBRARY_PATH:+:{LD_LIBRARY_PATH}}
export CUDA_HOME=/usr/local/cuda-9.0
source /opt/ros/kinetic/setup.bash
export ROS_MASTER_URI=http://localhost:11311
export ROS_IP=192.168.1.47
export LD_LIBRARY_PATH=/usr/local/lib:/opt/ros/kinetic/lib:/opt/ros/kinetic/lib/aarch64-linux-gnu:/usr/local/cuda-9.0/lib64:
export LD_LIBRARY_PATH=/usr/local/lib:/opt/ros/kinetic/lib:/opt/ros/kinetic/lib/aarch64-linux-gnu:/usr/local/lib:/usr/local/cuda-9.0/lib64

You may have the wrong CUDA installed. What sort of system are you on? Did you install CUDA yourself? How did you do it?

Hello thanks for your response
So I install CUDA 9.0 thourgh Jetpack 3.2 in the Jetson TX1
I have Ubuntu 16.04
TensorRT 3.0 GA
cuDNN 7.0.5
VisionWorks 1.6
Multimedia API
L4T

I also install ROS couple weeks ago, but I do not have any problem with it.
Since I am trying to install CAFFE i tried to verify if cuda works fine then is what happen when I run nvcc --version. So that is the reason why I think the problem is with the path format

I would recommend asking this question on the Jetson Forums for TX1.

I can move it there if you wish.

Also, I don’t think this belongs in your PATH export:

{LD_LIBRARY_PATH:+:{LD_LIBRARY_PATH}}

but I also don’t think its the source of the problem here.

ok I just post it