NVIDIA 430.x driver CUDA 10.1 compatibility with GeForce rtx 2080ti

Did anyone get into some issues with the installation of centos 7 CUDA 10.1 package (tried both with rpm and runfile) with the recent NVIDIA drivers 430.xx (I have tried with 430.26)? It seems to be some incompatibilities: during the installation some components of older drivers (418.67) are required, which obviously can not be installed with the new drivers. I also noticed that rtx 2080ti card is not supported by 418.67 drivers.
I was suggested to install just cuda-toolkit rather than the whole package and the installation went fine, but then it seemed to cause troubles during gpu based applications.

Does anyone have any hints?
Thanks
Stefano

What’s the exact problem?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Dear all,
in the meantime I had to re-install the OS; then I tried to re-install NVIDIA drivers suggested for my cards (RTX 2080 ti) by the web site (430.64) and everything (nvidia-smi) seemed OK; I then installed cuda package (10.1 cuda-repo-rhel7-10-1-local-10.1.168-418.67-1.0-1.x86_64.rpm) and the installation went fine, but after that, when trying to fulfil devicequery and bandwidthtest I got “cudagetdevicecount returned 999” and “cudagetdeviceproperties returned 999”.
Also running nvidia-smi after the installation of cuda gave “nvidia-smi failed to initialize nvml driver/library version mismatch”. I then installed NVIDIA drivers 418.67 and everything seems to work properly now. Maybe this is just the way it must be, I had figured out I could have installed the latest NVIDIA drivers and the latest CUDA package.

Your opinions/hints will be appreciated,
thanks
Stefano