NVIDIA announces Jetson Nano Developer Kit

NVIDIA is pleased to announce the Jetson Nano Developer Kit!

The Jetson Nano Developer Kit is an AI computer for makers, learners, and developers and is available today for $99. It offers out-of-the-box compatibility with common peripherals, including many from Adafruit and Raspberry Pi, and we are adding new distributors including Sparkfun and SeeedStudio. Jetson Nano is supported by the latest JetPack 4.2 software release, along with Jetson AGX Xavier and Jetson TX2.

For those who want to design custom products, the production-ready Jetson Nano module with eMMC (instead of microSD card slot) will be available for $129 in June. The finalized collaterals for product and carrier board design will be released around that time.

Resources and Documentation (see all)

Distributors (see all)

Can I know max instance information ?

Hi gihoon.yang, can you elaborate on what you mean by max instances?

Are there any recommended SD card types? What is the maximum card size?

Hello,

are there any rumors when the nano dev kit will be available for sale? Currently distributors do not have it on storage. I am mainly interested in european market.

BR
Anana

16GB UHS-1 is the recommended minimum. I have also used it with a bunch of different 64GB cards. Let me check on if/what the limit is.

Hi Anana, it has begun shipping out, please see the list of distributors it is available through here: https://devtalk.nvidia.com/default/topic/1048643/jetson-nano/nvidia-announces-jetson-nano-developer-kit/

Silicon Highway is European distributor, so you may want to try through them first.

We are unaware of a limit to the SD card capacity, other than what the SD cards themselves can hold currently.

Hi Dusty, do you know if the Nano can support M.2 M Key and boot from NVME SSD. regards, H

Hi Henry, the Nano module could support it with an alternate carrier design, like Auvidea’s JN30 with M.2 Key M slot: https://auvidea.eu/product/70780/

The stock Nano devkit doesn’t support it, with the devkit you should want to use a USB3->SATA dongle or some adapter board for the M.2 Key E.

Do you think Jetson Nano + JetBot can do the deep reinforcement learning by learning obstacle itself and avoid the object obstacle during moving?

The JetBot software doesn’t currently use reinforcement learning, but in theory you could modify it to learn the task you described with RL. You would probably want to train it in simulator first, because it is easy to derive the reward function in simulator (as you can query the distance to objects and collisions, ect) whereas this is more difficult to do in real life (although you could perhaps add an ultrasonic or ranging sensor to your JetBot to determine this during training). There is a ROS Gazebo simulator available for JetBot, linked from the JetBot wiki.

Hi,
I can not connect to 192.168.55.1:8888 ?
I have tried all the possible diagnostics and proved my MAC’s USB is working fine, but NVIDIA still can’t connect.
I had written image for my microSD card following the “Getting Started with Jetson Nano Developper Kit”, and it working fine for “Hello AI World”.
Do you think I need to re-image the microSD card for the course “Getting Started with AI on Jetson Nano” ?
Please help!
Jong Lin

Hi,

I’d like to use WiFI-USB adapter on Nano, is there any adapter device has been tested on Nano?
Thanks so much

Harris Lai.

Hi Harris, please check the Jetson Nano Supported Components List for some example wireless adapters.

Hi
I saw the Edimax EW-7811 seems be supported, but I found it is for kernel 4.4 only, not for 4.9
So can’t be installed

Hmm, I am able to use EW-7811 on my system using the built-in rtl8192 driver.

I also have one of these TP-Link N150 which have driver built-in:

https://www.amazon.com/TP-Link-TL-WN722N-Wireless-network-Adapter/dp/B002SZEOLG

Hi dusty,

Thanks your information.
Due to I didn’t know how to active EW-7811 driver to work, so I download driver from company’s website, but it fails. I called to support team to confimr that it didn’t support.
By the way, I also bought another TP-Link AC1300, although spec. mentions it support Linux, but can’t work.
So I called to that company to ask. and get the same result, no support for kernel v4.9.

Could you please guide me how to active the wifi function via EW-7811 or…

Thanks a lot.

I’m not sure about TP-Link AC1300, but TP-Link N150 has the driver in JetPack (tested on 4.2.1).

You can follow these instructions for patched driver: https://github.com/pvaret/rtl8192cu-fixes#installation