What size (in GB) of SD card is recommended?

Hi all,

As indicated in the title, what is the recommended storage size of an SD card to use with the Nano?

Hi mathiti13,

The 16GB UHS-1 is the recommended minimum. We have also used it with a bunch of different 64GB cards.

Thanks

Thank you, just ordered a 64GB card.

Will it support 128gb??

Yes it should, we are unaware of a limit, other than the capacity of MicroSD cards on the market themselves.

1 Like

After I flash the image using etcher, I get multiple partitions. After insert the card to the nano board nothing comes up. Power connected, display cable connected and mouse/keyboard connected checked. Any suggestions for me???

Yes. A 128 GB microSD works fine for me.

Do you have a green LED on the board light up, indicating it is powered up? Which power supply are you using?

yes. I am using canakit power supply. output - 5v=2.5A.

One suggestion is to try using a different microUSB cable and power supply.

I used an old microUSB cable and what I thought was a capable USB port… the Nano didn’t boot.

I switched to a relatively new microUSB cable and 10 Watt USB wall wart and everything worked.

Edit:

Your supply sounds fine!

murali1842, are you getting a green LED on the board? Does the LED flash or go off after booting up?

If you have another MicroSD card, you might want to try it just to rule out any issue with that particular SD card.

@murali1842 I had an issue where the green light would stay on for a few seconds and go out. I went with a 5v 2.5A power supply, but still had issues. I swapped out my Samsung 64GB UHS-1 with UHS-3 and it booted fine.

FYi, it doesn’t work with a SANDisk 200Go micro SD.
Works fine with a cheap 32Gb Alfawise card.

It’s working fine on my 200gb sandisk ultra (SDSQUAR-200G-GN6MA) micro SD though.

Wow that exactly the one I tried…

Maybe I should try to format and flash it again then.

Thank you
(Not that many 200Gb microSD on the market I guess)

Hi everybody, after I flashed the image by etcher, and the green led turned on when i connected the power but nothing happening, what should i do? I used SanDisk extrem pro 128GB

The same thing happened to me with a 64GB SD card. Replacing my charger with a proper one (5V, 2.5A) solved it, so I think it is a power issue.

128GB SD card works. Just need to use something like disk management or gparted to eliminate the unallocated space.

Mine is running on a 400GB Sandisk Ultra.

32Gb minimum. Something has lately escaped nVidia with its “unattended-upgr” that I haven’t managed to install in a 16Gb as the “update” for some reason was left half (I suspect) and broke the distribution.