Nvidia driver - 525 installtaion

i am getting the following error while installation of driver- nvidia driver -525
i am using ubunut 18.04.6 LTS and my nvidia processor is NVIDIA GeForce RTX 2080 Ti/PCIe/SSE2

$ sudo apt install nvidia-driver-525
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
nvidia-driver-535 : Depends: libnvidia-gl-535 (= 535.113.01-0lambda0.18.04.1) but it is not going to be installed
Recommends: libnvidia-compute-535:i386 (= 535.113.01-0lambda0.18.04.1)
Recommends: libnvidia-decode-535:i386 (= 535.113.01-0lambda0.18.04.1)
Recommends: libnvidia-encode-535:i386 (= 535.113.01-0lambda0.18.04.1)
Recommends: libnvidia-fbc1-535:i386 (= 535.113.01-0lambda0.18.04.1)
Recommends: libnvidia-gl-535:i386 (= 535.113.01-0lambda0.18.04.1)
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

Hi @ayrusprofessional,

you should first do

sudo apt purge nvidia-driver-535
sudo apt auto-remove
sudo apt autoclean

Reboot!

to uninstall the previous driver before trying to downgrade.