Nvidia driver does not work on my x1 extreme

Hi,

I am runing Archlinux on a X1 extreme and when I try to use the nvidia driver I get the following log

[ 23665.576] (II) NVIDIA: The X server does not support PRIME Render Offload.
[ 23665.782] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[ 23665.782] (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error
[ 23665.782] (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
[ 23665.782] (EE) NVIDIA(GPU-0):     README for additional information.
[ 23665.782] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[ 23665.782] (EE) NVIDIA(0): Failing initialization of X screen
[ 23665.782] (II) UnloadModule: "nvidia"

nvidia-bug-report.log.gz (388 KB)

Looks like you tried to use render offload which needs a patched Xserver:
https://gitlab.freedesktop.org/aplattner/arch-xorg-server

There’s that, but it looks like it didn’t get that far because the nvidia kernel module couldn’t initialize the GPU. It’s hard to tell from the log because all of RmInitAdapter failures pushed the boot messages out of the dmesg log.

I noticed that bbswitch is loaded. I wonder if it powered the GPU off before the nvidia module had a chance to initialize. Can you please try blacklisting or uninstalling the bbswitch module?

I’ve uninstalled bbswitch but same issue happens

I can’t install the patched version of xorg because of a compilation issue https://gitlab.freedesktop.org/aplattner/arch-xorg-server/issues/1

Anything else I could try, anyway I can fix the RmInitAdapter issue so we can see more of the logs?

This might be defective hardware but also bios bugs or improper blacklisting of nouveau can trigger this. Please check for a bios update first, then shutdown (not reboot) the notebook. Turn it on again and right after boot, create a new nvidia-bug-report.log so that the boot messages doesn’t get visible and not pushed out by the rminitadapter messages.

I found one issue:

I was runnig gdm with wayland on the stock arch kernel and that broke everything, now that I’ve disabled it all is fine.

The other issue is still not solved, on https://aur.archlinux.org/packages/linux-clear/ I get the above error, I am not sure if anyone else is running arch with linux-clear maybe you have some pointers for me.