nVidia driver doesn't work for Dell Inspiron 15 7000 Gaming - (EE) No devices detected. - (EE) no screens found(EE)

Hi, everyone. First off I’d like to thank you all for your support and say that’s it’s highly appreciated as I’m facing a real hard time. I would try to provide as many info as I can regarding to the issue.

I just bought a brand new “Dell Inspiron 15 7000 Gaming” but can’t install the nVidia driver for the “GeForce GTX 1050 Ti Mobile” graphic card in my Fedora 27.

I used to install all the time these nVidia drivers in other computers and laptops, but I can’t make it whatsoever for this laptop.

uname -r

4.15.14-300.fc27.x86_64

lspci |grep -E “VGA|3D”

00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

I haven’t found any option to disable “UEFI Secure Boot” in BIOS. I don’t think this laptop has one. Nor Optimus Technology.

Here is the full “lshw” file (https://pastebin.com/raw/8bjYzaLD), in case it’s necessary to check out.

That’s a summary to what I did (over and over again):

  1. Format disk and install Fedora 27
  2. Update all packages and kernel (dnf update --check-updates) and reboot
  3. Install driver NVIDIA-Linux-x86_64-390.48.run (for Linux 64-bits) - I followed THOROUGHLY every single step from the awesome and full of details tutorial of “If Not True Then False” - https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

After the reboot it supposed to start the running perfectly… BUT it displays a black screen forever.

I checked the log Xorg log (/var/log/Xorg.0.log - full here: https://pastebin.com/raw/47H7mLMA) and got this:

[ 40.108] (II) NVIDIA GLX Module 390.48 Wed Mar 21 23:42:56 PDT 2018
[ 40.108] (II) LoadModule: “nvidia”
[ 40.108] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 40.108] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 40.108] compiled for 4.0.2, module version = 1.0.0
[ 40.108] Module class: X.Org Video Driver
[ 40.108] (II) NVIDIA dlloader X Driver 390.48 Wed Mar 21 23:18:15 PDT 2018
[ 40.108] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 40.108] (II) systemd-logind: releasing fd for 226:0
[ 40.109] (EE) No devices detected.
[ 40.109] (EE)
Fatal server error:
[ 40.109] (EE) no screens found(EE)
[ 40.109] (EE)

Based upon what I just described,
Does anybody know how to fix this issue of “(EE) No devices detected. - (EE) no screens found(EE)”?

If you need any other info, please just let me know.

Your support is highly appreciated. Thanks.

See this:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

Thank Geeez, it’s FIXED!

Everything I had to do was FORGET ABOUT NVIDIA INSTALLERS and start using package manager!

Basically all I did was running these commands:

Add RPM Fusion package manager - https://rpmfusion.org/Configuration#line-42

dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-(rpm -E %fedora).noarch.rpm

And then install the drivers - https://rpmfusion.org/Howto/NVIDIA

dnf install xorg-x11-drv-nvidia akmod-nvidia xorg-x11-drv-nvidia-cuda
dnf update -y

Thanks!