NVIDIA driver is not loaded. Ubuntu 19.10

This morning my nvidia drivers just stopped working. My system has been working without graphics issues for months

I’ve purged the drivers and re-installed them several times, I’ve verified it’s not the hardware by reverting to the Nouveau driver which “works” (it sees all my monitors, just is prune to crashes)

I’ve tried installing the nvidia driver from the website, but the install always freezes at 5% of building the DPKG components.

Not sure how to attach the bug report, but basic info:

  • uname -a: Linux khea 5.3.0-24-generic #26-Ubuntu SMP Thu Nov 14 01:33:18 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
  • Not sure what nvidia-smi is for, but it says it can't connect: NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
  • lspci: ``` 01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 650 Ti] (rev a1) (prog-if 00 [VGA controller]) Subsystem: Gigabyte Technology Co., Ltd GK106 [GeForce GTX 650 Ti] Flags: bus master, fast devsel, latency 0, IRQ 11 Memory at f6000000 (32-bit, non-prefetchable) Memory at e0000000 (64-bit, prefetchable) Memory at f0000000 (64-bit, prefetchable) I/O ports at e000 Expansion ROM at 000c0000 [disabled] Capabilities: [60] Power Management version 3 Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+ Capabilities: [78] Express Endpoint, MSI 00 Capabilities: [b4] Vendor Specific Information: Len=14 <?> Capabilities: [100] Virtual Channel Capabilities: [128] Power Budgeting <?> Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?> Capabilities: [900] Secondary PCI Express <?> Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia ```
  • I tried installing the 430 driver but it didn't make any difference.

Is there any other steps I can take to get this is a working state again?

I’ve followed the posts at the following links to no avail :(

[nvidia-bug-report.log.gz|attachment](upload://ueh18ifR5IMFLpWu9NGlVw2hGyt.gz) (121 KB)

After 5 hours, I got it to work.

My steps (incase something actually helped)

  • Again purged all nvidia stuff (apt purge 'nvidia*')
  • Disabled secure boot
  • Manually installed the nvidia drivers (built kernel module, etc.)
  • Manually uninstalled installed the nvidia drivers (built kernel module, etc.)
  • Used's apt to install the nvidia drivers

It was at this point that when shutting down my monitor actually used the proper resolution, and my second monitor also flickered.

On restart though, only 2/3 monitors were working, and X wouldn’t load (switched init levels, startx, etc, nothing)

Then I ran dpkg-reconfigure lightdm (I tried alternating between gdm and lightdm as per some advice I read earlier this morning), after setting lightdm as a default, I rebooted, and my system was back up!

Not sure why but the default order of my monitors had changed, but that was easy to fix in arandr, tweak default workspaces in i3, but after 5 hours I’m finally ready to start my work day…