Nvidia driver - no device found error (bug report attached ^_^)

nvidia-bug-report.log.gz (204.6 KB)

Nvidia driver 535 recoomended installed.

Dell XPS 7590, i9, GPU - Nvidia GeForce GTX 1650 (not running) only the INTEL UHD 630 is running

Many Thanks for your help :)

Hi there @slayer27.15 and welcome to the NVIDIA developer forums.

You are using driver verison 525.147.05 with the Open Source kernel modules. Please visit the Github for those for further information since they are considered BETA stage for GeForce GPUs.


1 Like

Hello @MarkusHoHo , thank you for addressing my post. I have changed settings since last post please see new nvidia-bug report attached. I just want my GPU to work no matter how basic/ outdated the settings. If you know a configuration that will work please let me know, I’m quite lost at the moment.
nvidia-bug-report.log.gz (204.6 KB)

PS: I will also now update my old post with new bug report/

Have a look at the following:

-> Installing NVIDIA driver version 550.54.14.
-> An alternate method of installing the NVIDIA driver was detected. (This is usually a package provided by your distributor.) A driver installed via that method may integrate better with your system than a driver installed by nvidia-installer.

Please review the message provided by the maintainer of this alternate installation method and decide how to proceed:

The NVIDIA driver provided by Ubuntu can be installed by launching the "Software & Updates" application, and by selecting the NVIDIA driver from the "Additional Drivers" tab.

(Answer: Continue installation)
-> Performing CC sanity check with CC="/usr/bin/cc".
-> Performing CC check.
WARNING: The Nouveau kernel driver is currently in use by your system.  This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding.
-> Nouveau can usually be disabled by adding files to the modprobe configuration directories and rebuilding the initramfs.

Would you like nvidia-installer to attempt to create these modprobe configuration files for you? (Answer: Yes)
-> One or more modprobe configuration files to disable Nouveau have been written.  You will need to reboot your system and possibly rebuild the initramfs before these changes can take effect.  Note if you later wish to reenable Nouveau, you will need to delete these files: /usr/lib/modprobe.d/nvidia-installer-disable-nouveau.conf, /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
-> nvidia-installer is not able to perform some of the sanity checks which detect potential installation problems while Nouveau is loaded. Would you like to continue installation without these sanity checks, or abort installation, confirm that Nouveau has been properly disabled, and attempt installation again later? (Answer: Continue installation)
-> Proceeding with installation despite the presence of Nouveau. Kernel module load tests will be skipped.

There is so much going wrong during installation, it would take too long going through all of it.

So let’s concentrate on this:

The NVIDIA driver provided by Ubuntu can be installed by launching the "Software & Updates" application, and by selecting the NVIDIA driver from the "Additional Drivers" tab.

I recommend a fresh installation of Ubuntu without any GPU driver installation! Only after Ubuntu has booted (using nouveau, which is ok), go into the “Software & Updates” application, select the “Additional Drivers” Tab and then select the recommended, highest version number *proprietary driver (not server) in that list.

Then follow all instructions exactly!

That should get your GPU to work as expected.

1 Like

nvidia-bug-report.log.gz (162.6 KB)

@MarkusHoHo I have done a fresh install. Then I installed the recommended driver from the “Driver manager app”. I installed Nvidia driver 535.161.07.

I tried Nvidia smi - no device found

Switched to performance mode

Still no device found. Please see report attached.

Thank you so much for your help so far

I hope this photo of the driver options is also helpful

Ok, thank you for all the effort you are going through!

I am afraid the log entries do not bode well. If you look at this thread: Ubuntu 21.10 with GeForce 1650: nvidia-drm fails to allocate NvKmsKapiDevice, and fails to register device (not the very last message but all the ones before that) your case looks very familiar.

So it might be connected to a problem with the mainboard in the laptop, or an actual hardware failure of the NVIDIA GPU.

I recommend checking the DELL support if possible and try the solutions/fix attempts form the above thread.