NVIDIA-SMI failed to communicate with GeForce GTX 1650 on ubuntu 20.04

PC: Nuvo-7160GC
OS: UBUNTU 20.04
Kernel Version: 5.19.11-051911-generic
Nvidia Driver: Installed with the GUI of additional drivers
Driver Version: nvidia-driver-515
Secure boot: Disabled
Output of lspci command

lspci | grep VGA

01:00.0 VGA compatible controller: NVIDIA Corporation TU117 [GeForce GTX 1650] (rev a1)

Output of prime-select:

sudo prime-select query


When I type

ls -ld /dev/nvidia*

I get:

ls: cannot access ‘/dev/nvidia*’: No such file or directory

I attach to this subject the output of the nvidia-bug-report.sh
nvidia-bug-report.log.gz (95.0 KB)

helpful informations:
gcc version : gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Ubuntu 18 was installed in this PC and everything was normal. I erased the ssd to get a fresh restart so that I can install Ubuntu 20.04 properly.

Hello @hayse7 and welcome to the NVIDIA developer forums!

Please blacklist the Nouveau driver on your system and try again. It seems to be loaded instead of the NVIDIA kernel driver.

For example like this:

$ sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
$ sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
$ sudo update-initramfs -u
$ sudo reboot

For more information on the Nouveau driver please refer to the Linux driver README, “8.1. Interaction with the Nouveau Driver”.

I hope this helps!

Hello @MarkusHoHo and thank you your reply. I blacklisted the nouveau driver and reinstalled nvidia-driver with GUI. the command lsmod | grep nouveau return nothing (I assume that the nouveau driver is not in use) and still don’t have nvidia device in /dev/nvidia*. Here is an update of the nvidia-bug-report
nvidia-bug-report.log.gz (97.8 KB)

Well, something did not quite work it seems

sept. 29 16:59:37 adsgrey /usr/lib/gdm3/gdm-x-session[1214]: (II) LoadModule: "nouveau"
sept. 29 16:59:37 adsgrey /usr/lib/gdm3/gdm-x-session[1214]: (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
sept. 29 16:59:37 adsgrey /usr/lib/gdm3/gdm-x-session[1214]: (II) Module nouveau: vendor="X.Org Foundation"
sept. 29 16:59:37 adsgrey /usr/lib/gdm3/gdm-x-session[1214]:         compiled for 1.20.3, module version = 1.0.16
sept. 29 16:59:37 adsgrey /usr/lib/gdm3/gdm-x-session[1214]:         Module class: X.Org Video Driver
sept. 29 16:59:37 adsgrey /usr/lib/gdm3/gdm-x-session[1214]:         ABI class: X.Org Video Driver, version 24.0

You might have to adjust the way you blacklist the nouveau driver on your system. I recommend to check the linked driver README.

Tried to add nouveau.modeset=0 to grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1 nouveau.modeset=0"

in the file /etc/modprobe.d/blacklist.conf added these lines

# Blacklist nouveau
blacklist nouveau
options nouveau modeset=0

in file /etc/modprobe.d/blacklist-framebuffer.conf I commented the line :

# blacklist nvidiafb

Still have same issues with the nvidia-driver.
If it helps I attached the output of journalctl -xe after tying to start nvidia-persistenced.service
jounal.txt (159.2 KB)

For some reason the NVIDIA kernel module is not found by X:

sept. 29 18:24:07 adsgrey /usr/lib/gdm3/gdm-x-session[1696]: (II) LoadModule: "nvidia"
sept. 29 18:24:07 adsgrey /usr/lib/gdm3/gdm-x-session[1696]: (WW) Warning, couldn't open module nvidia
sept. 29 18:24:07 adsgrey /usr/lib/gdm3/gdm-x-session[1696]: (EE) Failed to load module "nvidia" (module does not exist, 0)

But I can’t tell why that might be.
At this stage I would highly recommend a complete purge of the existing NVIDIA drivers, reboot, and reinstall.

If that does not work we should move the topic over into the dedicated Linux forums.

Hello @MarkusHoHo,
The solution to this problem was to remove and purge the installed nvidia driver and to install the open-gpu-kernel-modules. I encountred some problems with the installation but I found the solutions by searching the issues in the github repository.

1 Like

Great to hear it worked out in the end!

Still, it should be possible to use a fresh installed Ubuntu with the distro drivers out of the box. I am regularly verifying that myself on a test system to stay up to date.

In any case, good that you could solve your issue and are up and running now!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.