Nvidia eGPU driver installation failed on Ubuntu 18.04

Hi,

I have spent days to install the Nvidia driver for my 2080 Super eGPU with a thunderbolt connection on Ubuntu 18.04 and everything has failed. The thunderbolt connection is already authorized. I have a Windows 10 dual boot and it works perfectly with my eGPU. Here is my system:
PC: HP Spectre X360 laptop
OS: Ubuntu 18.04, kernel version: 5.4.0-42-generic
eGPU: Nvidia GForce 2080 Super + Razor Core X enclosure

Drivers that I’ve tried: Nvidia Website: NVIDIA-Linux-x86_64-450.66.run, and from PPA: nvidia-driver-450, nvidia-driver-440

Also, from the tutorial https://egpu.io/forums/builds/yoga-730-15-razer-core-x-nvidia-2060-super-kali-linux/#post-83515, I modified my /etc/default/grub and I blacklisted nouveau.

Currently, nvidia-smi* outputs *Failed to initialize NVML: Unknown Error* if using the driver in the .run file. If I use the PPA, I get an error about failed communication due to not having the correct driver. Also, I tried to generate an *nvidia-bug-report*, but I don't seem to have the script (running * sh nvidia-bug-report.sh doesn’t work).

Does anybody know how to get this to work?
Thank you in advance for your help.

nvidia-installer.log (3.6 KB)

@generix Could you help me with this? I see that you answer all the posts…

It doesn’t look like your external GPU is visible to the system at all. From the installer log:

Please check the output of lspci and your kernel log to see if the GPU is showing up anywhere.

Thanks for the response. No, the output of lspci shows no sign of Nvidia, but thunderbolt is authorized. Do you know which driver should I use? I have currently installed the driver from the .run file, but I remember I had an error about being unable to install nvidia-drm.

P.S. If it helps, I previously tried to install this on Ubuntu 16.04 and the lspci did not show any sign of the eGPU until after I semi-successfully installed the driver. The installation resulted in nvidia-smi to work, but no processes were running and I also had a black screen, thus I upgraded to Ubuntu 18.04 with the hopes of making the eGPU integration easier.

@aplattner, do you have any more clues on why this might be happening and how can I fix this?