NVIDIA Jetson Nano 2GB Developer Kit available now

Yes, you should be using this image for the Nano 2GB:

The image for Nano 4GB will not work on Nano 2GB.

Just received the Jetson Nano 2GB, put it in a little case, flashed the microSD, Very smooth startup.

First question: What about the coin cell? What size, what part number for the holder, and what does it back up? Does it keep the clock running, or does it do more?

Thanks for your reply.

Just wanna get clarity on one thing, If I purchase 2GB ram dev kit… Can I able to remove the module alone from the dev kit and can I use it with my custom product?

Pathetic service from nVidia

I am from India , I pre-ordered Jetson Nano 2GB dev kit from nvidia partner(through nvidia site) , I got a defective piece (its not booting ) so I raised a ticket and they asked me to ship it back ; I shipped them back ;they too tested it again and replied me back that it is not working and they are sending it to nvidia for replacement and it will take 2 weeks to get the replacement .

Why don’t they give me the replacement immediately as I got the defective piece from the box itself

Hi @tpobrienjr, I believe it should be the same as the Jetson Nano 4GB and keeps the RTC (real-time clock) when the device is unplugged, however you may want to post a new topic to confirm this. Here is a post that illustrates installing it on the Nano 4GB:

Hi @gautham.k.28, sorry about that - different distributors may handle RMA differently. I don’t believe that NVIDIA should normally be on the critical path for RMAs from distributors (i.e. we don’t typically repair a unit and send it back to user). It’s possible that this distributor may be waiting for new stock unrelated to your RMA, sorry about that.

Hi @yadavaprasath, technically it is feasible, however it is not recommended as the devkit warranty does not cover production use-cases. For more info, please refer to this FAQ:

dusty_nv,
Thanks. I think there’s enough info in the link to answer my questions. I appreciate your quick and helpful response.

SDK manager won’t work on Jetson Nano 2GB due to the requirement of 8GB memory, right?

Hi @janmouli, the SDK Manager itself is installed onto an x86 Linux PC that’s running Ubuntu (the PC is required to have 8GB memory, not the Jetson). The PC running SDK Manager will then flash the Jetson device over micro-USB cable.

However since Jetson Nano can use SD card, it’s recommended just to use the SD card image as shown here:

The SD card image already comes with the JetPack components pre-installed (CUDA, cuDNN, TensorRT, ect), so you don’t typically need to use SDK Manager to setup Jetson Nano. Just flash the SD card image to your SD card using Etcher from your PC, then put the SD card into your Nano.

Hi @Dusty, that is good to know. I spent days in trying to make jupyter working with opencv 4.5.0 on my Jetson Nano 2GB without luck. SDK Manager was tried but … Is there a way to make the combination (jupyter with opencv 4.5.0) work on the Jetson Nano 2GB? Thank you.

If you wish, you can use the l4t-ml container which already has JupyterLab installed. Here is how I install JupyterLab into container in the Dockerfile.

For latest OpenCV, you would need to build it from source - you can see @mdegans OpenCV build script here:

Hi @Dusty, I had trid JetPack 4.4.1 (L4T R32.4.4), JupterLab server worked but not opencv (4.1.1, the default one came along with the SD card image). Is there a way to make the default opencv 4.1.1 work with JetPack 4.4.1 (L4T R32.4.4)? I hope that is just me missing something.
I’ll give the mdegans’ repo a try for the latest opencv (4.5.1) even many others did not work on the Jetson Nano 2GB at this moment. Thank you.

If you are referring to the l4t-ml container, I don’t believe OpenCV 4.1.1 is installed into that container. You can add JetPack’s OpenCV 4.1.1 into a container like was done here: https://github.com/NVIDIA-AI-IOT/jetbot/blob/cbf6f1b5a3285ad3bbb18ec552ed79846d1e2529/docker/base/Dockerfile#L47

Or if you want to use the dlinano container, that already has JupyterLab + OpenCV 4.1.1 (see Getting Started with AI on Jetson Nano course)

You could also install JupyterLab directly onto your device (outside of container) like in this post: How to Install Jupyter Lab on JP4.4

It sounds like “dlinano container” could be a solution. Just wondering why the setup (jupyter+opencv+cuda) is so complicated with JetPack on Jetson Nano 2GB. I can’t believe that there is no straightforward ways to get the setup done. Anyway, thank you.

Nvidia released Linux kernel 4.9.140 patches for its ARM linux devices 2 years ago, and there was no new kernel updates since then.
You can’t install a newer Linux kernel with support of Wi-Fi 6. And you need to know that Nvidia stops releasing updates for their old devices even if they still runs on the same CPU.
And if you ask Nvidia on their forum, about when new kernel support going to be released, they will tell you “Customer can try to do that by their own”.


Jetson Nano runs on the 5 years old hardware, since it is using the same GPU and CPU as used in the first revision of Nintendo Switch, but JN has 2 times less GPU core count.
When buying this you should be ready that you may stuck on the kernel 4.9.140 forever with no kernel security patches.
If you agree with Ubuntu to install all updates to v20 it will break all the GPU drivers.
So the only way to make things work is to not buy that device or sell it if you have already.
Either you will need to wait 5 more years until community release some good software support of it.

@julyighor, The insight is appreciated. Thanks.

@janmouli

I’ve tried building my OpenCV script on a 2GB nano. My tips for that would be:

  • use a swap file/device
  • start it at night and i’ll be done in the morning

If you have any issues, please report them on GitHub with any logs and i’ll try to get around to looking into the issue. I do have a 2GB Nano to test with. I’ve been busy recently with work, but I try to prioritize popular repos like the OpenCV build script.

1 Like

If you install JupyterLab natively onto your device (outside of container), then it should have access to the OpenCV that comes with JetPack. If you are running it inside of a container, then you need to install OpenCV into the container as well.

Hi @julyighor, we plan to upgrade Jetson devices to newer 5.x kernel and 20.04 LTS next year.

1 Like