NVIDIA Jetson TX2 10 bit decode support


Is 10 bit decode supported on the Jetson TX2?

I am trying to play a 1920x1080 10 bit .h265 file using gstreamer. (I have used both version 1.8.3 and 1.12.3). My operating system is Ubuntu 16.04 LTS and my kernel version is 4.4.15. Instead of playing the 10 bit file smoothly, gstreamer only plays one badly colored frame. .h265 files encoded in 8 bit play smoothly and with the correct colors though.

This is the pipeline I am using:
gst-launch-1.0 filesrc location=/home/nvidia/graffiti_fhd_60_sdr.265 ! h265parse ! omxh265dec ! nveglglessink

I have even tried using the nvvidconv plugin to do 10 to 8 bit conversion according to https://devtalk.nvidia.com/default/topic/1019783/jetson-tx2/decode-10-bit-hevc-video/ but my results are the same.

gst-launch-1.0 filesrc location=/home/nvidia/graffiti_fhd_60_sdr.265 ! h265parse ! omxh265dec ! nvvidconv ! nveglglessink

How do I resolve this? Is 10 bit decode supported on the TX2?


Hi mzfern,
Can you please share your h265? We support 10-bit HEVC decoding on r28.1/TX2. No issue is seen with the h265 streams we have. Please share yours to reproduce the issue.

Hi could you please try with jellyfish-3-mbps-hd-hevc-10bit.mkv from http://jell.yfish.us/?

I demuxed it using ffmpeg

ffmpeg -i jellyfish-3-mbps-hd-hevc-10bit.mkv -c:v copy -bsf hevc_mp4toannexb jellyfish-3-mbps-hd-hevc-10bit.hevc;

mv jellyfish-3-mbps-hd-hevc-10bit.hevc jellyfish-3-mbps-hd-hevc-10bit.h265;

I tested it using
gst-launch-1.0 filesrc location=jellyfish-3-mbps-hd-hevc-10bit.h265 ! h265parse ! omxh265dec ! nvvidconv ! nveglglessink

I also tested the mkv file without demuxing and got the same results
gst-launch-1.0 filesrc location=jellyfish-3-mbps-hd-hevc-10bit.mkv ! matroskademux ! h265parse ! omxh265dec ! nvvidconv ! nveglglessink

Hi mzfern,

Confirmed we can play “jellyfish-3-mbps-hd-hevc-10bit.mkv” with you provide two pipeline on r28.1/TX2.
Which image are you using? JetPack3.1 ?


Hi I tried installing with JetPack 3.1 and it worked for me. I was using 3.0. I had a bit of trouble getting 3.1 to install but it worked.