Nvidia please release CUDA for Ubuntu 20.04 on arm64 (needed for Jetson Nano)

Hello all,

I noticed a Nvidia dev released their own Xubuntu 20.04 image intended for Jetson. This is great because Ubuntu 20.04 is an LTS release Xubuntu 20.04 Focal Fossa L4T R32.3.1 - Custom Image for the Jetson Nano

However, I am running into a problem where I cannot install CUDA on my Jetson now. I noticed that CUDA is available on Ubuntu 20.04, but only for x86/x64 architecture. It is NOT available for arm64. The latest version of CUDA for arm64 is compiled for Ubuntu 18.04 and thus has some extreme dependency breakage when trying to apply the current CUDA arm64 package on the Xubuntu 20.04 image released by the aforementioned Nvidia dev

Is it possible Nvidia can release CUDA compiled for Ubuntu 20.04 on the arm64 architecture? It seems the prior dev gave us the newest Ubuntu LTS to work from, but we still lack many libraries/tools (e.g., CUDA) to make real use of 20.04 on the Jetson

1 Like

Hi Victor,

I’m the guy that released the Ubuntu 20.04 image for the nano.

I made sure that everything that is included with the standard L4T BSP is also Included in my image.

If there are packages that I missed or additional libraries that you would like to install that don’t come with the BSP release please give me the full .Deb package names and I’ll see what I can do.

In the mean time you can try unpacking .deb packages yourself and modifying the dependencies.

Remove any that conflict with 20.04 then repack the .deb and install manually. The libraries will most likely still function correctly because in most cases the only thing that prevents them from being installed is a newer version of a couple dependencies.

You could also try unpacking the .deb file then manually copy and past the required libraries and any config files to their correct locations.


Thanks Chris for the detailed reply. I’ll give it a try this weekend!

@mr.chrismitchells Is this using the 4.9.14 kernel?

Hi Jake,

The image includes two kernels, both are version 4.9.140.

One of the kernels is the standard tegra kernel that Nvidia included with BSP version 32.3.1 and the other Kernel is one that I modified to support KVM on the nano.

You can select which kernel you want to boot via the extlinux.conf file.


Dang. I was hoping you had worked some super magic and got a newer kernel running:) Still cool though.

Hi Chris,

I’m having a bit of trouble with CUDA and am wondering if you can help. I’m running the Xubuntu image you provided.

Regarding CUDA, I tried to check the cuda install at /proc/driver/nvidia/version but it was not there. I also tried the ‘nvcc’ command but it returns nothing

I did notice some other parts of L4T are installed but not CUDA. Any idea?


Nvidia has not seemed to release CUDA for 20.04 on arm64? @mr.chrismitchells

Seems some components of CUDA like deviceQuery test are also missing

That’s under planning, but no clear schedule yet. Thanks

Hello VictorB,

Am starting on the jetson nano kit. The kit is running on Ubuntu 20.04. How do i get CUDA running?. I have added the paths but i still get the error when i run nvcc --version
thanks in advance

CUDA has strong dependencies to the environment. You’d have to go back to Ubuntu 18.04.

1 Like

It has been several months. Still no 20.04 Release?

I don’t get it. It seems to me that Nvidia is pushing AI on small SBCs and is a year behind supporting the current LTS. This is disastrous for supporting ROS Noetic/Foxy which rely on Python 3 OpenCv 4. Heck Even Raspberry Pi 4 can run 20.04. with GPU.

Without Cuda the Jetson Nano is a brick.


@alan.federman we don’t yet have an update for 20.04, sorry about that. You can run ROS Noetic/Foxy on 18.04 though. There are example Dockerfiles for them in this project:


Although you can also install them outside of Docker on 18.04 following a similar procedure from those Dockerfiles.

I think LTS version update is not a simple work to NVIDIA.
Because 18.04 is running on the small Jetson devices and on the huge DGX systems as well.
All of the system should be updated together.

not a serious solution.