Nvidia RTX 3070Ti laptop GPU ambiguous TGP

I recently bought a laptop with RTX 3070Ti GPU. The GPU is supposed to be having 150W TGP, which is easily achievable in windows while playing games. However, when I use the GPU in Linux for training my deep learning models, the TGP is 115W. I tried setting power limit but that’s not allowed. Upon viewing the settings, it shows that my GPU’s max power limit is 150W but “default power limit is 115”.
How do I get my GPU to use full power while in ubuntu??


Hey. thanks for replying.

the directory /usr/share/doc/NVIDIA_GLX-1.0/ is not available on my system. I also tried searching nvidia-dbus.conf inside /usr/share and found nothing…Can you help me with it…

edit: I checked and nvidia-dbus.conf already exists in /etc/dbus-1/system.d/nvidia-dbus.conf
however, I cannot start the service

I have RTX 3070Ti, Intel i7-12650H

nvidia-powerd is what you need to enable from my understanding. I’m not sure why it isn’t installed for you, it is for me. Did you install the drivers correctly?

Hey. I’ll just redo the installation ig. Can you point me to some guide…? I would like to install latest cuda, cudnn and nvidia drivers. I did it using cuda installation guide last time.

It has been years since I last used Ubuntu but from what I remember there was an “additional drivers” GUI app that let you install them. Otherwise, the normal GUI installer has an option I think.

The CUDA SDK is always packaged separately. On Ubuntu it looks like nvidia-cuda-toolkit is the package you need.

Okay so when I manually install nvidia drivers, powerd service works. but when I install cuda, it shows nvidia-driver-535 in “following new packages will be installed” and the service doesn’t work anymore. same error as above. I’d really appriecate any help I can get here…

As a general rule you shouldn’t be installing the .run file but using your distro’s packages.

I downloaded PopOS’s 22.04 Nvidia LTS ISO and booted it. nvidia-powerd is included with the drivers and is even enabled by default. If it’s OK to use PopOS instead of vanilla Ubuntu then I would give that a shot.