Why is my Laptop Nvidia card limited in Power Limit?

My Laptop is rated to run at 140W max for the graphics card I have. This was advertised when purchasing the product. Yet the limit is set to 115W. Apologies if it’s been already discussed and solution is crystal clear, it’s just not enabled by default for a common folk like myself.

There are guides online suggesting to enable nvidia-powerd service which enables DynamicBoost. I have done that, yet the power cap remains. Even whilst running games, it will not go above 115W

~ nvidia-smi --query --display=POWER

==============NVSMI LOG==============

Timestamp                                 : Tue Mar 12 05:45:11 2024
Driver Version                            : 550.54.14
CUDA Version                              : 12.4

Attached GPUs                             : 1
GPU 00000000:01:00.0
    GPU Power Readings
        Power Draw                        : 18.25 W
        Current Power Limit               : 115.00 W
        Requested Power Limit             : N/A
        Default Power Limit               : 115.00 W
        Min Power Limit                   : 1.00 W
        Max Power Limit                   : 140.00 W


~ systemctl status nvidia-powerd        
● nvidia-powerd.service - nvidia-powerd service
     Loaded: loaded (/usr/lib/systemd/system/nvidia-powerd.service; enabled; preset: disabled)
     Active: active (running) since Tue 2024-03-12 04:40:07 GMT; 51min ago
   Main PID: 524 (nvidia-powerd)
      Tasks: 3 (limit: 18896)
     Memory: 1.2M (peak: 1.8M)
        CPU: 1.749s
     CGroup: /system.slice/nvidia-powerd.service
             └─524 /usr/bin/nvidia-powerd

Mar 12 04:40:07 ArchPC systemd[1]: Started nvidia-powerd service.
Mar 12 04:40:07 ArchPC /usr/bin/nvidia-powerd[524]: nvidia-powerd version:1.0(build 1)
Mar 12 04:40:07 ArchPC /usr/bin/nvidia-powerd[524]: Dbus Connection is established

This appears to be only Linux case after noticing it’s not giving the same performance as Windows.

Is this a known bug? Is there an issue I can follow? I am running Arch

Graphics card in question: RTX 3070 Mobile


Update, installed sudo pacman -S power-profiles-daemon on Arch and enabled Performance mode using FN+Q on Lenovo Laptop. This brings the wattage to 140W while in Game. I also have nvidia-powerd enabled.

I use KDE so when installing power-profiles-daemon you get a new widget, but changing the mode via widget doesn’t seem to change anything. Only using FN+Q shortcut.

Using KDE 6.0.1

This is resolved Thank you :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.